平台提供SDK包套餐项,供您下载并调用,帮助您简化App的开发任务。在您下载SDK套餐项时,可以同时下载安全图片等开发App所必需的文件。

下载SDK

  1. 进入自有品牌App的SDK和插件页面,并选择APP SDK页签。
    APP SDK
  2. 下拉选择SDK配置项的版本号(一般建议选择最新版本)。

    SDK套餐项的功能版本号即API Level,用来解决新老SDK套餐项不兼容问题,每个API Level包含一组SDK套餐项,不同API Level的SDK套餐项功能不同。详细介绍请参见API Level版本介绍

    说明 如果您当前已经集成了SDK,且API Level为7及以下,建议您升级至最新版本。升级操作请参见升级SDK至API Level 8(Android)升级SDK至API Level 8(iOS)
  3. 选择SDK套餐项。
    SDK包括以下套餐项:
    • 基础包(必选)
    • 用户账号(必选)
    • 消息推送

      消息推送还需要额外配置参数,详细请参见移动应用推送开发指南

    • 设备控制
    • 配网
    • 蓝牙设备接入框架
  4. 单击iOS SDK下载Android SDK下载
    下载到本地的文件为压缩包,解压后包含以下文件:
    • iOS

      Podfile文件、安全图片

    • Android

      dependency.gradle文件、安全图片

      说明 由于下载Android安全图片需要先上传apk签名文件,如果您没有上传apk签名文件,压缩包里就不包含安全图片。安全图片的介绍请参见集成安全图片

集成Android SDK

集成SDK前,需确保已集成安全图片。Android App推荐开发工具为Google官方的Android Studio(建议使用最新版本3.0.x)。

添加依赖文件
  1. 将下载的Android SDK Pom dependency.gradle文件放到Module的根目录下。
  2. 在模块根目录的build.gradle文件中,添加以下代码。
    apply from:'dependency.gradle'

集成iOS SDK

集成SDK前,需确保已集成安全图片。本SDK采用cocoapods管理业务模块。

  1. 将下载的iOS SDK Podfile文件放到工程文件夹根目录。
  2. 修改文件中的target名称与xcode工程的设置一致。
  3. 执行pod update

后续操作

完成下载并集成SDK后,您需要初始化SDK,参见SDK初始化SDK初始化