当您的应用已经接入了ARMS应用监控,并且想要使用ARMS业务监控时,您可以选择升级探针。

限制条件

  • 您需要接入业务监控的应用是Java应用,并且已接入应用监控,详情请参见准备工作概述
  • 只有2.6.2+ 版本的应用探针支持ARMS业务监控功能。

操作流程

dg_business_workflow
说明 目前业务监控处于公测阶段,因此在您准备接入业务监控前,需要先加入钉钉答疑群:30004969,并告知工作人员您的阿里云账号ID和应用名称。工作人员在后台为您配置白名单后,您可以开始安装或升级探针的操作。扫描以下二维码图片加入钉钉答疑群。
dg__business_dingding

为容器服务Kubernetes版Java应用升级探针

您需要将应用探针升级到2.6.2+ 版本才能使用ARMS业务监控功能。

具体操作步骤如下:

  1. 登录容器服务管理控制台,在左侧导航栏选择应用 > 发布,在Helm页签查看ack-arms-pilot组件的更新时间。
    tab_business_helm
    • 如果更新时间在2019年12月之前,则需要先升级ack-arms-pilot组件后才能升级探针,请执行步骤2
    • 如果创建时间在2019年12月之后包括2019年12月,则直接执行步骤4
  2. 在左侧导航栏选择集群 > 集群,在集群列表页面上的目标集群右侧操作列,单击控制台
    pg_business_ack_cluster_list
  3. 在左侧导航栏从命名空间列表选择arms-pilotarms-pilot-system,在概况页面的容器组区域,单击右下角的 图标,然后再单击删除,删除arms-pilot组件对应的容器组。
    sc_business_delete_pods

    删除容器组后,会自动创建新的容器组。
  4. 重启您的业务Pod。
    应用探针自动升级。
  5. 可选:在容器内执行cat /home/admin/.opt/ArmsAgent/version命令,查看应用探针的版本号。
    若版本号以2.6.2开头,则表示应用探针版本已成功升级至2.6.2+ 版本,此时您可以创建业务监控任务监控您的应用。