Specified access key is not found

原因分析 :

该问题由于阿里云的API网关没有找到鉴权的 AccessKeyId 导致。

  • 如果是必现,说明 AccessKeyId 设置错误。

  • 如果是偶发,则是API网关鉴权时临时出错,出现这种异常时,进行重试即可。

解决方案

如果是 AccessKeyId设置错误,可参照如下步骤操作:

  • 主账号登录RAM控制台

  1. 使用阿里云账号登录RAM控制台

  2. 将鼠标移动至页面右上方的账号图标,单击accesskeys

  • 获取子账号AK(首次登录用户)

  1. 在安全提示页面,单击开始使用子用户AccessKey

    fig1
  2. 如果未创建RAM用户,在系统跳转的RAM访问控制台的新建用户页面,创建RAM用户。如果是获取已有RAM用户的Accesskey,则跳过此步骤。

  3. RAM访问控制台的左侧导航栏,选择人员管理 > 用户,搜索需要获取AccessKey的用户。

  4. 单击用户登录名称,在用户详情页认证管理页签下的用户AccessKey区域,单击创建新的AccessKey

  5. 手机验证页面,获取验证码,完成手机验证,单击确定

  6. 创建AccessKey页面,查看AccessKeyId和AccessKeySecret。可以单击下载CSV文件,下载AccessKey信息或者单击复制,复制AccessKey信息。

    fig2
  • 给RAM用户授权

为RAM用户授权,授予RAM子账号管理移动推送(MPush)的权限。