全部产品
阿里云办公

源库版本号检查

更新时间:2018-01-03 09:27:55

这个检查项主要检查数据传输服务是否支持源数据库的版本号。数据传输服务支持的各种源数据库的版本如下:

源数据库类型 支持的版本号
MySQL 全量迁移支持 5.0、5.1、5.5、5.6、5.7,当进行增量迁移时,仅支持 5.1、5.5、5.6、5.7
SQL Server 全量迁移支持 2005、2008、2008R2、2012、2014、2016,当进行增量迁移时,仅支持 2005、2008、2008R2、2012、2014
Oracle 10g、11g、12c
PostgreSQL 全量迁移支持 9.2、9.3、9.4、9.5,当进行增量迁移时,仅支持 9.4.8、9.5
MongoDB 3.0、3.2

当版本检查失败时,只能将源数据库升降级到数据传输服务支持的版本范围后,再进行预检查。