本篇文档为您介绍了安装原版PHP SDK的环境要求,以及安装原版PHP SDK、卸载原版PHP SDK的操作步骤及说明。

使用说明

原版SDK已不再维护,建议使用支持Composer的升级版SDK,详细内容请参见安装(Composer)

前提条件

您已经开通了视频点播服务。开通步骤请参见开通视频点播服务

环境准备

PHP 5.3及以上版本,您可通过php -v命令查看当前的PHP版本。关于如何安装PHP,请参见PHP官网下载合适的版本安装。

安装SDK

  1. 在您的PHP项目中添加空文件夹aliyun-php-sdk(为便于统一管理SDK文件)。
  2. aliyun-openapi-php-sdk下载整个源码,解压后复制aliyun-php-sdk-corealiyun-php-sdk-vod两个文件夹到aliyun-php-sdk目录下。
说明 建议aliyun-php-sdk-core使用1.3.8版本及以上,aliyun-php-sdk-vod使用2.15.1版本及以上。
目录结构说明目录
序号 说明
PHP集成的SDK
应用程序
说明 Demo.php为示例名称,此应用程序为用户自定义,可根据实际业务需要设置名称。

卸载SDK

直接删除本地SDK目录即可。