未安装SASL和SSL模块。

问题现象

报错客户端

  • C++
  • PHP
  • Node.js
  • 其它包装C++的客户端

可能原因

未安装SASL和SSL模块。

解决方案

执行以下命令安装SASL和SSL。
  • 安装SSL:sudo yum install openssl openssl-devel
  • 安装SASL:yum install cyrus-sasl{,-plain}
注意 该解决办法只适用CentOS平台,其它平台请搜寻类似办法。