问题描述
消息服务MNS的订阅成功后收不到消息,并且在日志中查不到相关记录。
问题原因
可能是由于订阅时配置了FilterTag参数。该参数描述了订阅中消息过滤的标签,标签一致的消息才会被推送。
解决方案
请参考如下步骤进行排查。
检查消息服务MNS的日志,确认查找不到相关记录。关于如何查看消息服务MNS的日志,请参见日志管理。
检查订阅时是否设置了FilterTag参数。根据实际情况,选择是否继续保留该参数。关于该参数的介绍,请参见订阅接口规范。
如果您的问题仍未解决,您可以在阿里云社区免费咨询。