远程连接Windows服务器提示“身份验证错误,要求的函数不受支持”的错误

问题描述

使用远程桌面连接工具登录Windows系统的阿里云轻量应用服务器失败,并提示以下报错。

身份验证错误,要求的函数不受支持
可能是由于 CredSSP 加密 Oracle 修正。

问题原因

微软针对Windows系统发布的升级补丁导致出现该问题。该问题只存在于Windows10操作系统,对Windows7等操作系统无影响。

解决方案

阿里云提醒您:

  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。

请参见下列方法,在本地Windows客户端中,将加密 Oracle 修正的保护级别修改为易受攻击:

  1. 登录本地Windows客户端,单击开始,找到并单击运行,然后输入gpedit.msc并单击确定,打开本地组策略编辑器。
  2. 然后在左侧栏中的计算机配置中依次选择管理模板>系统>凭据分配,然后在右侧栏中双击加密 Oracle 修正
  3. 未配置改成已启用,再将保护级别从已缓解改成易受攻击,然后依次单击应用>确定即可。
  4. 配置完成后,您可以重新尝试远程连接该服务器。

适用于

  • 轻量应用服务器
  • 云服务器ECS

如果您的问题仍未解决,您可以在阿里云社区免费咨询,或提交工单联系阿里云技术支持。