阿里云首页

视频点播上传视频长时间处于“上传中”状态

问题描述

通过视频点播上传视频,发现该视频长时间处于“上传中”状态。

问题原因

该问题常见的原因如下:

  • 只生成上传凭证但没有上传视频
  • 视频文件太大导致上传时间较长
  • 网络问题

解决方案

您可以按照以下步骤排查并解决问题:

  • 只生成上传凭证但没有上传视频:
    1.  完成视频点播的上传需要两个步骤:
      1. 首先通过调用获取视频上传凭证的接口(CreateUploadVideo)获取上传凭证,这个时候会产生一个“上传中”的空videoid,实际上是没有上传视频。
      2. 然后需要通过获取到的uploadAuth、uploadAddress、videoId上传您本地的资源。之后才会出现“正常”状态下的资源。
    2. 需要检查您是否只调用了获取上传凭证的接口,却没有真正的调用上传接口,上传demo请参见Java上传SDK
  • 视频文件太大导致上传时间较长:
    确认上传文件大小以及处于“上传中”状态的时间是否处于合理范围。通过控制台、上传SDK和客户端上传工具等方式上传文件时,默认会使用分片上传,最大支持上传48.8TB的单个文件;上传SDK同时也提供简单上传功能,其最大支持上传5GB的单个文件。
    说明:视频点播无法上传0秒视频。
  • 网络问题:
    若您是通过控制台上传视频,您需要确认上行带宽是否满足需求。

适用于

  • 视频点播
首页 视频点播上传视频长时间处于“上传中”状态