全部产品
云市场
    OSS PHP SDK报“Use of undefined constant CURLOPT_CLOSEPOLICY - assumed”错误

OSS PHP SDK报“Use of undefined constant CURLOPT_CLOSEPOLICY - assumed”错误

更新时间:2019-09-02 19:44:28

问题描述

使用OSS PHP SDK时,报错如下错误。

Use of undefined constant CURLOPT_CLOSEPOLICY - assumed 
‘CURLOPT_CLOSEPOLICY’  in
D:\phptools\www\pia\oss_php_sdk_20140625\lib\requestcore\requestcore.class.php on line 610:

 

问题原因

根据以上问题描述,有以下两种原因。

  • 在PHP5.6.0中去掉了CURLOPT_CLOSEPOLICY变量。
  • 未安装curl命令或者指定curl的环境变量。

 

解决方法

根据以上两种原因,有以下两种对应的解决方法。

  • 由于官方SDK还没有更新,您可以将CURLOPT_CLOSEPOLICY变量用对应的代码删除即可。
  • 安装curl命令或者指定curl环境变量。

 

适用于

  • 对象存储 OSS

 

如果您的问题仍未解决,您可以在阿里云社区免费咨询,或提交工单联系阿里云技术支持。