本文主要介绍企业级分布式应用服务EDAS应用无法访问页面及RPC服务无法调用的处理方案。

问题描述

通过HTTP方式无法访问页面,远程过程调用RPC服务无法调用。

问题原因

  1. 网络问题、应用配置路径错误、应用本身错误等。
  2. 服务器到注册中心网络不可达、服务权限限制、服务调用超时等。

解决方案

  1. 通过HTTP方式无法访问页面。
    • 通过服务器本机 curl/Ping等命令确认网页URL是否正常。如果正常,检查访问机到服务机的网络,将网络问题解决后进行重试。
    • 如果不是网络问题,请检查Tomcat日志错误,解决所有日志错误为止。
    • 排查HTTP路径,特别是应用设置的Context配置和端口配置。设置Tomcat参数
    • 执行如下命令,查看java程序进程ID。
      ps -ef |grep java
    • 排查程序运行是否正常,依次执行如下命令,通过JVM工具排查。
      sudo jstack -F 进程ID
      sudo jstat -class [vmid] [interval] [count];
      jmap -heap 2083
      • [vmid]:VM的进程号,即当前运行的java进程号。
      • [interval]:间隔时间,单位为秒或毫秒。
      • [count]:打印次数,如果缺省则打印无数次。
  2. RPC服务无法调用。
    • 检查服务调用应用和发布应用是同一个账号,网络可达。服务器端口是否被屏蔽导致服务无法访问。
    • 检查服务Tomcat应用日志错误,解决所有日志错误,直到服务列表能正常查询到服务。
    • 查看/home/admin/logs/hsf/hsf.log日志,确认具体的错误码,具体错误及解决方案可以详细 HSF 错误码