Link IoT Edge提供专业版(LE Pro)、标准版(LE Standard)、轻量版(LE Lite)三个版本的产品,本文为您介绍三个版本产品的能力区别以及对软硬件的不同要求。

  • LE Pro是基于Docker方式运行的软件包,包含Link IoT Edge所有功能。
  • LE Standard是基于二进制自包含包运行的软件包,可以根据运行的软硬件环境选择对应的安装包。
  • LE Lite是一款开源软件包,可以使用官方的自包含软件包,也可以使用源码自主编译,该版本提供了远程运维功能。

产品能力

产品能力 专业版 标准版 轻量版
远程SSH服务 支持 支持 支持
远程文件服务 支持 支持 支持
远程Web隧道 支持 支持 支持
MQTT上云 支持 支持 支持
子设备管理 支持 支持 不支持
设备接入驱动 支持C、Node.js、Python 支持C、Node.js 不支持
函数计算(业务小程序) 支持C、Node.js、Python 支持C、Node.js 不支持
可视化场景联动 支持 支持 不支持
流数据分析 支持 不支持 不支持
AI模型运行框架 支持 不支持 不支持
消息路由 支持 支持 不支持
云服务集成 支持 支持 不支持
业务应用隔离 容器隔离 进程隔离 不支持

环境要求

三个版本对硬件的要求如下:
硬件参数 专业版 标准版 轻量版
CPU架构 x86-64
  • x86-64
  • ARMv8-64
  • ARMv7 VFPv3硬浮点型
  • ARMv7软浮点型
  • x86-64
  • ARMv8-64
  • ARMv7 VFPv3硬浮点型
  • ARMv7软浮点型
CPU主频 ≥ 2 GHZ ≥ 1 GHZ 不限制
RAM ≥ 2 GB ≥ 128 MB ≥ 1 MB
磁盘 ≥ 2 GB ≥ 128 MB ≥ 1 MB
三个版本对软件的要求如下:
系统环境 专业版 标准版 轻量版
Linux 依赖docker工具,且docker版本 > v17.03
  • Linux kernel version ≥ 2.6.32(for x86-64)
  • Linux kernel version ≥ 2.6.32(for ARMv7软浮点&硬浮点)
  • Linux kernel version ≥ 3.7.0(for ARMv8-64)
  • Linux kernel version ≥ 2.6.32(for x86-64)
  • Linux kernel version ≥ 2.6.32(for ARMv7软浮点&硬浮点)
  • Linux kernel version ≥ 3.7.0(for ARMv8-64)
Windows
  • 依赖bash执行环境,如安装git bash工具
  • 依赖docker工具,且docker版本 > v17.03
不支持
  • Windows7
  • Windows10
MacOS 依赖docker工具,且docker版本 > v17.03 不支持 > OSX 10.10
Cloud Shell 不支持 仅支持搭建Link IoT Edge v1.8.2及以上版本软件 不支持