获取SDK

物联网视频服务提供Android版本的应用端SDK,实现视频设备的直播、录像播放、语音对讲和图片获取等功能。本文介绍SDK的支持系统、开发环境以及配置步骤。

前提条件

  • 视频设备已接入视频型实例,详细操作,请参见设备接入

  • 开发前的环境要求如下表所示。

    类别

    说明

    系统版本

    支持Android 4.4及以上版本。

    Java版本

    支持Java 1.7及以上版本。

    API LEVEL

    支持Android SDK API LEVEL 18及以上版本。

    Android Studio版本

    支持Android Studio 2.3以上版本。

配置步骤

  1. 创建Android Studio工程。

  2. 配置依赖。

    1. 在您创建的Android Studio工程,根目录下的build.gradle文件中,添加Aliyun Maven仓库地址。

      maven {
                       url "http://maven.aliyun.com/nexus/content/repositories/releases"
                  }           
    2. app文件夹下的build.gradle文件中添加如下依赖。

      implementation('com.aliyun.iotx:linkvisual-media:1.2.14.1')
  3. 混淆配置。

    proguard-rules.pro文件中添加如下混淆配置。

    # keep and don't warn Link Visual
    -dontwarn com.aliyun.iotx.linkvisual.**
    -dontwarn com.google.android.exoplayer2.**
    -keep class com.aliyun.iotx.linkvisual.media.** { *; }