您可以通过直接添加阿里云SDK依赖包的方式安装阿里云PHP SDK。

前提条件

在安装和使用阿里云PHP SDK前,确保您已经:
  • 请确认您的系统满足环境要求
  • 已经注册阿里云账号并生成访问访问密钥(AccessKey)。详细步骤请参考创建AccessKey
说明 强烈建议使用cURL扩展,并使用TLS后端编译cURL 7.16.2+。

安装步骤

请参考以下步骤,使用Composer安装依赖。

如果在您的系统上全局安装Composer,您可以在项目目录中运行以下内容,将 Alibaba Cloud Client for PHP 添加为依赖项。
composer require alibabacloud/client

通过 Composer 和其他方式安装的详细信息,请查看安装说明

在安装完成后,您可以使用OpenAPI Explorer来生成相关API的Demo,并应用在您的项目中。如需了解更多,请参考更详细的安装及使用指南

PHP SDK GitHub地址

PHP SDK核心库