uni-app跨平台开发扩展支持在阿里云小程序开发者工具中将uni-app工程编译为微信、百度、字节跳动小程序。

前提条件

确保您安装的是最新版本小程序开发者工具。访问这里下载最新版本:https://docs.alipay.com/mini/ide/download

步骤一:安装uni-app跨平台开发扩展

完成以下操作,安装uni-app跨平台开发扩展:

  1. 打开小程序开发者工具,选择跨平台小程序 > uni-app
  2. 单击+创建小程序项目。
  3. 在左侧工具栏,单击插件市场图标,单击uni-app跨平台开发扩展的安装按钮。
  4. 安装完成后,单击启用

步骤二:开启微信小程序编译

启用后,完成以下步骤开启微信小程序编译:

  1. 在IDE上部菜单栏,单击扩展 > volans-extension-uniapp > 微信IDE调试
    说明 确保您打开的是小程序uni-app项目工程,否则无法打开uni-app跨平台开发扩展配置页面。
  2. 微信开发者工具文本框中输入微信开发者工具的安装路径,然后单击保存
    微信开发者工具的默认安装路径如下,请根据实际情况输入。
    • MacOS:/Applications/wechatwebdevtools.app
    • Windows:C:/Program Files (x86)/Tencent/微信web开发者工具
    注意
    • 只有首次使用时需要配置IDE安装路径。
    • 微信开发者工具必须打开服务端口,否则无法唤醒IDE。详细信息,请参见微信 IDE - 安全设置
  3. 单击开始编译
    编译后,若IDE路径配置正确,并自动打开微信小程序IDE,并加载编译后的微信小程序产物。

步骤三:开启字节跳动小程序编译

完成以下操作,开启字节跳动编译:

  1. 跨平台开发扩展页面,选择字节跳动
    字节
  2. 单击点击安装依赖包进行安装。
  3. 根据需要单击开发编译生产编译
    开发编译和生产编译,产物路径是相同的。

步骤四:开启百度小程序编译

完成以下操作,开启百度编译:

  1. 跨平台开发扩展页面,选择百度
    百度
  2. 单击点击安装依赖包进行安装。
  3. 根据需要单击开发编译生产编译
    开发编译和生产编译,产物路径是相同的。