全部产品

分布式事务问题

数据访问代理是否支持分布式事务

数据访问代理支持与分布式事务的集成使用。版本要求:

  • 数据访问代理 V2.9.5 或更高版本

  • 分布式事务 V2.5.2 或更高版本

具体配置信息请参考 集成分布式事务使用

在数据访问代理 V2.9.5 之前的版本中,如果事务中存在跨数据库的 SQL,数据访问代理将会返回错误 ERROR 7031: Cannot execute update SQLs cross databases in transaction