在运行社区版Java SDK代码收发消息前,您需按照本文提供的步骤来准备环境。

操作步骤

  1. 通过下面两种方式可以引入依赖(任选一种):
    • 使用Maven方式引入依赖。
      <dependency>
          <groupId>org.apache.rocketmq</groupId>
          <artifactId>rocketmq-client</artifactId>
          <version>4.5.2</version>
          <!--更新为最新版本-->
      </dependency>
      <dependency>
          <groupId>org.apache.rocketmq</groupId>
          <artifactId>rocketmq-acl</artifactId>
          <version>4.5.2</version>
          <!--更新为最新版本-->
      </dependency>                           
    • 下载依赖JAR包。

      社区版Java SDK支持连接阿里云消息队列RocketMQ版,推荐使用的社区版Java SDK版本为4.5.2。请访问http://rocketmq.apache.org/release_notes/release-notes-4.5.2/下载。

  2. 代码里涉及到的资源信息,例如阿里云消息队列RocketMQ版实例、Topic和Group ID等,需要到阿里云消息队列RocketMQ版控制台上创建。
    更多信息,请参见阿里云账号快速入门中的 创建资源

后续步骤