ARMS业务监控以代码无侵入的方式,可视化定义业务请求,并为您提供贴合业务的丰富性能指标与诊断能力。在使用业务监控之前,您需要先完成为您的Java应用安装探针这一准备工作。

限制条件

  • 业务监控仅支持监控Java应用。
  • 只有2.6.2+版本的应用探针支持ARMS业务监控功能。
  • 需要安装JDK。

操作流程

dg_business_workflow
说明 欢迎您使用钉钉扫描下方二维码或者搜索钉钉群号30004969加入钉钉群进行反馈。
dg__business_dingding

为Java应用手动安装探针

如果您是初次使用业务监控,并且未使用过应用监控的新用户,则按照应用监控的文档说明安装最新版本的探针。具体操作,请参见为Java应用手动安装Agent

为手动安装探针的Java应用升级探针

如果您是初次使用业务监控,并且已使用过应用监控的老用户,则需在使用业务监控前,将应用探针版本升级至2.6.2+版本。升级探针前,需要先卸载探针后再重新安装探针:

  1. 卸载探针。
    具体操作,请参见卸载Agent
  2. 重新安装探针。
    具体操作,请参见为Java应用手动安装Agent