本文将指导您使用智能接入网关双机直挂组网的方式,通过静态路由接入上云,提高网络的可用性。

场景示例

本教程以下图所示的本地网络架构为例。三层交换机下联两台二层交换机,本地客户端和服务器通过二层交换机接入,两台智能接入网关直挂到三层交换机上互为备份将本地机构接入阿里云。

双机直挂HA上云

前提条件

  • 您已经在阿里云华北2(北京)地域创建专有网络VPC(Virtual Private Cloud)。具体操作,请参见创建和管理专有网络
  • 您已经创建云企业网,且云企业网已经加载了VPC。具体操作,请参见创建云企业网实例

网段规划

以下为本场景网段规划示例值,如您需要自行规划网段,请确保要互通的网段没有重叠。

项目 IP地址
阿里云北京VPC网段 10.0.0.0/16
出口路由器地址 端口G1:192.168.100.2/30
端口G2: 192.168.200.2/30
智能接入网关1
  • WAN端口5:192.168.100.1/30,下一跳:192.168.100.2
  • LAN端口4:192.168.50.1/24,启用HA,且虚IP地址为192.168.50.254。
智能接入网关2
  • WAN端口5:192.168.200.1/30,下一跳:192.168.200.2
  • LAN端口4:192.168.50.3/24,启用HA,且虚IP地址为192.168.50.254。
三层交换机
  • 端口G11:划分到VLAN 10下
  • 端口G12:划分到VLAN 10下
  • VLAN 10:192.168.50.2/24
本地机构 172.16.0.0/12

步骤一:购买智能接入网关

您在智能接入网关管理控制台购买设备后,阿里云会将智能接入网关设备寄送给您,并创建一个智能接入网关实例方便您管理网络配置。

  1. 登录智能接入网关管理控制台
  2. 智能接入网关页面,选择购买智能接入网关 > 创建智能接入网关(硬件版)
  3. 在购买页面,根据以下信息配置智能接入网关,然后单击立即购买
    • 区域:智能接入网关使用区域。本示例选择中国内地
    • 实例类型:选择智能接入网关设备规格。本示例选择SAG-1000
    • 已有SAG硬件:选择是否已有智能接入网关硬件设备。本示例选择
    • 版本:智能接入网关设备版本。本示例使用默认标准版
    • 购买数量:智能接入网关设备购买数量。本示例选择2
    • 区域:智能接入网关使用的带宽区域。该区域类型和智能接入网关设备使用区域保持一致,且无法修改。
    • 实例名称:智能接入网关实例名称。

      名称长度为2~128个字符,以大小写字母或中文开头,可包含数字、半角句号(.)、短划线(-)和下划线(_)。

    • 带宽峰值:选择通信网络的带宽峰值。本示例选择30 Mbps
    • 购买时长:选择购买时长。
  4. 确认订单信息,然后单击确认购买
  5. 在弹出的收货地址对话框,填写网关设备的收货地址,然后单击立即购买
  6. 在弹出支付页面,单击确认支付

您可以在智能接入网关实例页面查看是否下单成功。系统会在下单后两个工作日内发货。如果超期,您可以提交工单查看物流状态。

查看下单状态

步骤二:激活绑定智能接入网关设备

收到网关设备后,请检查设备配件是否完整,详情请参见SAG-1000设备说明

  1. 在顶部菜单栏,选择目标区域。
  2. 智能接入网关页面,找到目标实例。
  3. 在目标实例操作列单击激活
  4. 单击目标实例ID,在智能接入网关实例详情页面,单击设备管理页签,输入智能接入网关设备序列号。
    添加设备
  5. 单击添加设备
  6. 重复同样的步骤,将第二台智能接入网关设备绑定到该实例。

步骤三:连接智能接入网关设备

激活、绑定智能接入网关设备后,您还需要将智能接入网关连接到本地机构中。

在执行此操作前,请保持网关设备启动且4G信号正常,已经连接到阿里云。本操作以智能接入网关1为例进行配置,请根据同样的步骤和网络规划配置智能接入网关2。

  1. 智能接入网关页面,找到目标网关实例ID。
  2. 在智能接入网关实例详情页面,单击设备管理页签。
  3. 在页签左侧区域,单击端口角色分配
  4. 端口角色分配页面,单击目标端口操作列下的修改,修改端口角色,然后单击确定
    本示例本地机构使用WAN(端口5)和LAN(端口4),更多端口详情请参见分配端口角色
  5. 通过网线,将智能接入网关的WAN(端口5)连接到出口路由器的G1端口上。
  6. 通过网线,将智能接入网关的LAN(端口4)连接到三层交换机的G11端口上。

步骤四:端口配置

连接好网关设备后,您可以在智能接入网关管理控制台对设备进行端口配置。

本操作以智能接入网关1为例进行配置,请根据同样的步骤和网络规划为智能接入网关2配置端口。

  1. 登录智能接入网关管理控制台
  2. 智能接入网关页面,单击目标网关实例ID。
  3. 在智能接入网关实例详情页面,单击设备管理页签。
  4. 在页签左侧区域,单击LAN口管理
  5. LAN(端口4)区域,单击编辑
  6. LAN(端口4)配置页面,根据以下信息配置端口,然后单击确定

    智能接入网关1:

    • 连接类型:选择静态IP
    • 接口地址:LAN端口IP地址。本示例输入192.168.50.1
    • 掩码地址:LAN端口IP地址掩码。本示例输入255.255.255.0

    智能接入网关2:

    • 连接类型:选择静态IP
    • 接口地址:LAN端口IP地址。本示例输入192.168.50.3
    • 掩码地址:LAN端口IP地址掩码。本示例输入255.255.255.0
  7. 在页签左侧区域,单击WAN口管理
  8. WAN(端口5)区域,单击编辑
  9. WAN(端口5)配置页面,根据以下信息配置端口,然后单击确定

    智能接入网关1:

    • 连接类型:选择静态IP
    • IP地址:WAN端口IP地址。本示例输入192.168.100.1
    • 掩码:WAN端口IP地址掩码。本示例输入255.255.255.252
    • 网关:网关IP地址。本示例输入192.168.100.2

    智能接入网关2:

    • 连接类型:选择静态IP
    • IP地址:WAN端口IP地址。本示例输入192.168.200.1
    • 掩码:WAN端口IP地址掩码。本示例输入255.255.255.252
    • 网关:网关IP地址。本示例输入192.168.200.2
    说明 配置网关后,智能接入网关设备会添加一条默认路由。

步骤五:配置路由

智能接入网关的WAN口和LAN口配置好后,您需要配置线下路由同步方式将本地机构路由同步到云上,同时配置静态路由为云上流量去往本地机构指定出口。

本操作以智能接入网关1为例进行配置,请根据同样的步骤和网络规划为智能接入网关2进行配置。

  1. 智能接入网关页面,单击目标网关实例ID。
  2. 在智能接入网关实例详情页面,单击网络配置页签。
  3. 在页签左侧区域,单击线下路由同步方式
  4. 选择静态路由,然后单击添加静态路由,配置静态路由信息,然后单击确定

    静态路由添加为本地机构要和云上互通的网段:172.16.0.0/12。

    线下路由2
  5. 保持在该智能接入网关实例页面,单击设备管理页签。
  6. 在页签左侧区域,单击路由管理,然后单击添加静态路由
  7. 添加静态路由页面,添加去往本地机构的静态路由。
    参数 说明
    目标网段

    智能接入网关1:172.16.0.0/12

    智能接入网关2:172.16.0.0/12

    下一跳IP

    智能接入网关1:192.168.50.2

    智能接入网关2:192.168.50.2

    端口 两台智能接入网关均选择端口4(LAN)
    路由添加静态

步骤六:配置HA

本场景中通过配置HA来解决智能接入网关单点路由失效的问题。

本操作以智能接入网关1为例进行配置,请根据同样的步骤和网络规划为智能接入网关2进行配置。

  1. 登录智能接入网关管理控制台
  2. 使用以下任意一种方式进入设备管理页面。
    • 单击目标智能接入网关实例ID,进入目标智能接入网关实例详情页面,单击设备管理
    • 选择目标智能接入网关实例操作列的更多 > 设备管理
  3. 设备管理页面,单击HA管理
  4. HA信息区域,单击编辑图标。
  5. HA配置页面,选择HA模式。
    配置详情请参见下表。
    配置 说明
    HA模式 两台智能接入网关均选择静态
    端口 两台设备均选择LAN4(LAN)。
    虚IP 智能接入网关的虚拟IP地址,此场景中两台智能接入网关均使用192.168.50.254。
  6. 单击保存

步骤七:配置三层交换机和出口路由器

由于不同厂商的交换机配置命令有所区别,具体请参考厂商的配置手册。以下示例仅作参考。
  • 交换机
    说明 同一个智能接入网关设备运行OSPF协议接口的网络类型需要配置为p2p,否则不能正确地计算路由。
    配置端口IP:
    
    
    interface GigabitEthernet 0/12
    switchport access vlan 10                 //将连接智能接入网关1 LAN口的端口划分到VLAN 10下
    
    
    interface GigabitEthernet 0/14
    switchport access vlan 10                 //将连接智能接入网关2 LAN口的端口划分到VLAN 10下
    
    interface  vlan 10
    ip address 192.168.50.2 255.255.255.0      //客户端网关地址
    
    ip route 0.0.0.0 0.0.0.0 192.168.50.254    //交换机去往外网的路由。
                        
  • 出口路由器路由配置
    配置静态路由
    
    ip route 192.168.100.1 255.255.255.252  192.168.100.2  //出口路由器去往智能接入网关1的路由
    ip route 192.168.200.1 255.255.255.252  192.168.200.2  //出口路由器去往智能接入网关2的路由
                        

步骤八:配置网络连接

在配置好网关设备后,您需要配置网络连接,将本地网络接入阿里云。

  1. 创建云连接网。
    1. 登录智能接入网关管理控制台
    2. 在左侧导航栏,单击云连接网
    3. 云连接网,单击创建云连接网
    4. 创建云连接网页面,配置云连接网名称,然后单击确定
      云连接网名称长度为2~100个字符,以大小写字母或中文开头,可包含数字、下划线(_)和短划线(-)。创建云连接网
  2. 配置网络连接。
    1. 登录智能接入网关管理控制台
    2. 智能接入网关页面,单击需要进行网络配置的实例操作列的网络配置
    3. 绑定网络详情页签下,单击添加网络,选择云连接网并选择网络实例,单击确定
      云连接网
  3. 绑定云企业网。
    1. 登录智能接入网关管理控制台
    2. 在左侧导航栏,单击云连接网
    3. 单击需要绑定云企业网的云连接网实例操作列的绑定云企业网
    4. 绑定云企业网页面,选择要绑定的云企业网实例,单击确定
      绑定后,云连接网中的网关设备便可以和云企业网实例中已加载的网络实例(VPC或VBR)通信。云企业网
  4. 配置安全组。
    配置一条允许本地机构访问VPC的安全组规则。具体操作,请参见添加安全组规则

步骤九:访问测试

完成上述配置后,您可以通过本地机构的客户端访问VPC中部署的云资源验证配置是否生效。