解决 utdid 冲突

冲突说明

如果您在使用了 mPaaS 的同时也使用了阿里系 SDK,可能会遇到 utdid 冲突。当您遇到此种情况,请参考以下解决方案。

解决办法

移除 mPaaS utdid 库,使用其他阿里系 SDK 提供的 utdid。

操作步骤

  1. 确认 mPaaS 所使用的 utdid SDK 的版本,以便您选取相同或相近的版本。

    'com.taobao.android:utdid4all:1.5.1.3@jar'
  2. 获取 mPaaS 所使用的 utdid SDK 的 group:artifact 信息。

    'com.alipay.android.phone.thirdparty:utdid-build'
  3. 移除 mPaaS utdid SDK。

    • AAR 方式

      configurations {
      all*.exclude group:'com.alipay.android.phone.thirdparty', module: 'utdid-build'
      }
    • mPaaS Inside & 组件化(Portal & Bundle)

      mpaascomponents {
      excludeDependencies = [
         "com.alipay.android.phone.thirdparty:utdid-build"
      ]
      }
  4. 加入接口包。

    • 10.1.68.8 及以下基线如果您使用了 utdid 相关的 API,请下载 jar 包 utdid-build-1.1.5.3-api.jar.zip,并引入 (compile/implementation) 到工程参与编译。

    • 10.1.68.9 及以上基线无需任何操作。

阿里云首页 移动开发平台 mPaaS 相关技术圈