解决 fastjson 冲突

冲突说明

mPaaS 使用 fastjson 来进行 JSON 解析,如果您在项目中也使用了 fastjson,就会出现 fastjson 冲突。

解决办法

移除 mPaaS 中的 fastjson-build。

操作步骤

  1. 确认当前 mPaaS 所使用的 fastjson 版本。

    'com.alibaba:fastjson:1.x.x.android@jar'
  2. 获取 mPaaS 使用的第三方 SDK 的 group:artifact 信息。

    'com.alipay.android.phone.thirdparty:fastjson-build'
  3. 移除 mPaaS 库。

    • AAR 方式如果您是原生 AAR 方式接入 mPaaS,则无需主动移除,gradle 依赖传递会自动使用较高的版本。mPaaS 选择使用的版本具有较高的稳定性和安全性,建议使用 mPaaS 提供的版本。如果版本不一致,请在上线前对 mPaaS 功能进行测试以保证稳定性。

    • mPaaS Inside & 组件化(Portal & Bundle)

      mpaascomponents {
      excludeDependencies = [
        "com.alipay.android.phone.thirdparty:fastjson-build"
      ]
      }
阿里云首页 移动开发平台 mPaaS 相关技术圈