全部产品

HBase Java SDK 下载

注意:目前已依赖社区版HBase客户端,无法升级到上述推荐的版本。

  • HBase 1.x版本客户端对应1.x版本的HBase集群。

  • HBase 2.x版本客户端对应2.x版本的HBase集群。

  • HBase增强版用户推荐使用2.x版本客户端。

HBase 1.x版本

<dependency>
  <groupId>com.aliyun.hbase</groupId>
  <artifactId>alihbase-client</artifactId>
  <version>1.8.6</version>
</dependency>

HBase 2.x 版本

<dependency>
  <groupId>com.aliyun.hbase</groupId>
  <artifactId>alihbase-client</artifactId>
  <version>2.8.6</version>
</dependency>

通过Maven方式,升级成与社区版本相应的阿里云HBase客户端,请参见历史版本(Maven方式)

通过Jar包替换的方式,升级成与社区版本相应的阿里云HBase客户端,请参见历史版本(Jar包替换)