阿里云首页

Liunx系统的ECS实例中文字体显示乱码

免责声明: 本文档可能包含第三方产品信息,该信息仅供参考。阿里云对第三方产品的性能、可靠性以及操作可能带来的潜在影响,不做任何暗示或其他形式的承诺。

问题描述

通过客户端工具远程连接Linux系统的阿里云ECS实例时,发现中文字体显示乱码。

问题原因

造成该问题的原因如下:

  • Liunx系统未安装中文字体,默认Liunx系统语言不支持中文显示,需要单独安装中文语言包使系统支持中文显示。
  • 客户端工具字符集设置问题

解决方案

阿里云提醒您:

  • 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
  • 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
  • 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。

请根据现场实际情况,选择以下对应的步骤。

Liunx系统未安装中文字体

下列操作以CentOS 7.8操作系统为例,其它版本的CentOS系统或者其他发行版本(如Redhat、Debian、Ubuntu等)对应的配置和命令行请参阅相应的官方文档。

  1. 登录ECS实例,详情请参见连接方式概述
  2. 执行以下命令,确认当前系统使用的语言为英文。
    echo $LANG
  3. 执行以下命令,查看当前系统是否安装中文语言包。
    locale -a | grep "zh_CN"
    系统显示类似如下,zh表示中文,CN表示中国,gb18030、gb2312、gbk、utf8为字符集。
    zh_CN
    zh_CN.gb18030
    zh_CN.gb2312
    zh_CN.gbk
    zh_CN.utf8
    若未安装中文语言包,请执行以下命令安装。
    sudo yum groupinstall "fonts"
  4. 执行以下命令,编辑/etc/locale.conf配置文件。
    vim /etc/locale.conf
    1. i键切换至编辑模式,将LANG=en_US.UTF-8修改LANG=zh_CN.UTF-8,将当前系统语言修改为中文。
    2. 修改完成后,按下Esc键后,输入:wq并回车,保存并关闭配置文件。
  5. 执行以下命令,使配置生效。
    source /etc/locale.conf
  6. 执行以下命令,重启服务器。
    reboot
  7. 若重启服务器后,当前系统语言仍显示为英文,请编辑/etc/profile.d/lang.sh配置文件,将zh*) LANG=en_US.UTF-8修改为zh*) LANG=zh_CN.UTF-8,保存并退出。修改之后的内容如下图所示。
    Dingtalk_20210709104253.jpg

客户端工具字符集设置问题

本文以Xshell为例,打开Xshell客户端,默认语言选择Unicode (UTF-8),重新登录实例即可。

适用于

  • 云服务器ECS

如果您的问题仍未解决,您可以在阿里云社区免费咨询,或提交工单联系阿里云技术支持。

首页 Liunx系统的ECS实例中文字体显示乱码