本文介绍如何在本地搭建可以运行威胁检测Java SDK示例的开发环境。

安装JAVA版本

在安装和使用Alibaba Cloud SDK for Java前,您需要先安装Java环境。您可以参考以下步骤安装Java环境。

  1. 安装Java环境。
    Alibaba Cloud SDK for Java要求使用JDK1.6或更高版本。
  2. 添加Maven依赖 (推荐)。
    如果您使用Maven管理Java项目,可以通过在pom.xml文件中添加Maven依赖安装Alibaba Cloud SDK for Java。
    <dependency>
        <groupId>com.aliyun</groupId>
        <artifactId>aliyun-java-sdk-core</artifactId>
        <version>4.4.6</version>
    </dependency>

    如果Maven没有从中央存储库下载jar包,则需要将此依赖项添加到pom.xml文件中,否则将报告NoClassDefFoundError 异常。

    <dependency>
        <groupId>com.google.code.gson</groupId>
        <artifactId>gson</artifactId>
        <version>2.8.5</version>
    </dependency>