通过HBase Java SDK访问云原生多模数据库Lindorm宽表引擎,请参考以下说明升级HBase客户端版本。

前提条件

已安装Java环境,Alibaba Cloud SDK for Java要求使用JDK1.8或更高版本。

使用须知

  • HBase 1.x版本客户端对应1.x版本的HBase集群。
  • HBase 2.x版本客户端对应2.x版本的HBase集群。
  • 新用户推荐使用2.x版本客户端。
注意 如果目前已依赖社区版HBase客户端,那么无法升级到上述推荐的HBase客户端版本,可以通过以下方式升级HBase客户端版本。

升级HBase Java SDK

  • 如果客户端是HBase 1.x版本,您可以在pom.xml文件中添加Maven依赖来升级HBase Java SDK。
    <dependency>
      <groupId>com.aliyun.hbase</groupId>
      <artifactId>alihbase-client</artifactId>
      <version>1.8.7</version>
    </dependency>
  • 如果客户端是HBase 2.x版本,您可以在pom.xml文件中添加Maven依赖来升级HBase Java SDK。
    <dependency>
      <groupId>com.aliyun.hbase</groupId>
      <artifactId>alihbase-client</artifactId>
      <version>2.8.7</version>
    </dependency>