Adobe在2020年12月31日停止对Flash Player的官方支持,主流浏览器例如Google Chrome、Mozilla Firefox、Microsoft Edge、Apple Safari等都将停止对Flash Player的支持。2020年12月31日后,您将无法再继续使用Flash Player。本文介绍Adobe停止Flash Player的官方支持对使用阿里云堡垒机产品的影响和解决方案。

对阿里云堡垒机的影响范围

Adobe停止Flash Player的官方支持对阿里云堡垒机V3.2.3及以前的历史版本在控制台上的部分操作会产生影响,V3.2.6及以后的新版本不受影响。以下表格介绍Adobe停止Flash Player的官方支持对堡垒机各版本产生的具体影响。

版本 影响
V2.1.6、V2.1.7、V2.1.11、V3.0.3、V3.1.2、V3.1.3、V3.1.9
  • 无法在堡垒机控制台通过上传文件的方式批量导入主机或用户。
  • 无法在堡垒机控制台查看实时会话和播放历史会话。
V3.2.3 无法在堡垒机控制台查看实时会话和播放历史会话。
V3.2.6~最新版本 无影响。

解决方案

您可以使用以下方案解决Flash Player停止服务对使用堡垒机产生的影响:
  • 更换浏览器:您可以使用较低版本的Chrome浏览器(86.0或更低版本)或自带Flash Player的浏览器。更换浏览器后您可以正常使用批量导入用户、主机功能,可以正常播放实时会话和历史会话。
  • 使用离线播放器(仅V3.1.X版本适用):在云盾堡垒机控制台右上角选择admin > 工具下载,在工具下载页面依次下载并安装Adobe AIR 4.0和离线播放器。使用离线播放器可以正常查看已经下载到本地的历史会话。关于工具下载的更多信息,请参见工具下载