RPC服务无法调用
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问题描述
RPC客户端调用服务时,服务无法调用。
问题原因
服务器到服务注册中心网络不可达、服务权限限制、服务调用超时等。
解决方案
RPC服务无法调用时,请参考以下操作进行排查:
- 查看
catalina.out
日志,检查服务提供者是否正常注册到服务注册中心,如果出现[Register-ok]
和[Publish-ok]
字样,说明服务提供者正常注册到服务注册中心。 - 检查服务调用应用和发布应用是否在同一个账号,网络是否可达。
- 如果正常,请进行下一步。
- 如果网络异常,请参见网络异常时如何抓取数据包,排查、修改网络连接。
- 在
/etc/hosts
配置文件中查看设置的服务器IP地址是否与实际一致。- 如果一致,请进行下一步。
- 如果不一致,请参见EDAS控制台中启动应用失败提示“UnknownHostException”错误,修改
/etc/hosts
配置文件与实际地址服务器一致。
- 检查服务器端口是否被屏蔽导致服务无法访问。
- 如果正常,请进行下一步。
- 如果端口被屏蔽,请参见添加安全组规则,设置对应端口的安全组规则。
- 请检查Tomcat日志错误,如何查看日志,请参见EDAS如何使用日志文件排查问题。
- 如果不存在日志错误,请进行下一步。
- 如果存在日志错误,解决所有日志错误,直到在服务列表中能正常查询到服务即可,如何查询服务请参见查询HSF服务。
- 查看
/home/admin/logs/hsf/hsf.log
日志,检查是否存在相应的报错。- 如果有相应的错误码,请参见HSF错误码,根据对应的错误码进行解决。
- 如果还是无法解决,请联系阿里云技术支持协助处理。
适用于
- 企业级分布式应用服务EDAS
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