问题描述
网站接入Web应用防火墙后,出现405阻断页面或者HTTP返回码为405。

问题原因
接入Web应用防火墙后出现405报错的原因如下:
- 请求被高频Web防护拦截。
- 请求被自定义防护策略。
- 请求被正则防护引擎阻断。
- 请求被CC安全防护拦截。
解决方案
- 如果是部分用户访问网站提示405错误,请参见以下操作进行处理:
- 请参见设置扫描防护,检查是否被高频Web防护拦截。如被高频Web防护拦截,请您确认是正常用户请求,解封即可。
- 请确认是否因设置的自定义防护策略拦截了请求,如果确认被拦截的用户请求是正常用户请求,请参见设置访问控制/限流白名单,将其加入白名单,放行因触发访问控制/限流相关规则被误拦截的业务请求。
- 如果是所有用户访问网站都提示405错误,请参见以下操作进行排查:
- 请参见设置自定义防护策略,为域名关闭自定义防护策略,查看是否还有405错误。如果不再出现,说明您所配置的自定义防护规则误拦截了请求,需要您找到对应规则并将其删除。
- 如果关闭自定义防护策略开关后问题仍然存在,请参见设置正则防护引擎,可以为域名关闭正则防护引擎,查看问题是否仍然存在。
- 如果问题消失,建议您将正则防护引擎的防护规则组设置为宽松规则组(默认为中等规则组),或者您可以通过日志服务分析有问题的URL,并参见设置自定义防护策略,添加一条自定义防护策略,放行访问该URL的请求。
- 如果关闭正则防护引擎后问题仍然存在,请参见设置CC安全防护,为域名关闭CC安全防护,查看问题是否仍然存在。
- 如果问题消失,建议您将CC安全防护的模式设置为防护(如果本来就是防护模式,请忽略),或者您可以通过日志服务分析有问题的URL,并参见设置自定义防护策略,添加一条自定义防护策略,放行访问该URL的请求。
- 如果关闭CC安全防护后问题仍然存在,说明不是WAF误拦截。
适用于