文档

未使用不推荐的Elasticsearch实例版本

更新时间:

Elasticsearch实例所使用的版本未在参数指定的不推荐版本范围内,视为“合规”。

应用场景

不同版本的Elasticsearch实例具有不同的优缺点,用户需要根据自己的实际需求和应用场景,选择适合自己的版本。

风险等级

默认风险等级:高风险。

当您使用该规则时,可以按照实际需求变更风险等级。

检测逻辑

  • Elasticsearch实例所使用的版本未在参数指定的不推荐版本范围内,视为“合规”。

  • Elasticsearch实例所使用的版本在参数指定的不推荐版本范围内,视为“不合规”。

规则详情

参数

说明

规则名称

未使用不推荐的Elasticsearch实例版本

规则标识

elasticsearch-instance-version-not-deprecated

标签

Elasticsearch

自动修正

不支持

规则触发机制

配置变更

规则支持的资源类型

Elasticsearch实例

规则入参

esVersion(默认值:5.5.3、5.6.0、6.3.2、6.7.0、6.8.0、7.10.0、7.16.0、8.5)

修正指导

Elasticsearch实例所使用的版本是参数指定的推荐版本。具体操作,请参见升级版本

  • 本页导读 (1)