Kubernetes版本概览及机制

更新时间: 2024-01-23 10:29:38

容器计算服务ACS基于原生的Kubernetes提供以容器为核心的解决方案。由于Kubernetes版本不断升级,因此容器计算服务ACS会定期发布支持的Kubernetes版本。本文为您介绍容器计算服务ACS的Kubernetes版本支持机制。

版本发布

容器计算服务ACS支持的Kubernetes大版本详细信息如下。

版本号

版本说明

状态

发布时间

过期时间

1.24

ACS发布Kubernetes 1.24版本说明

已发布

2023年10月

2024年09月

版本发布周期

容器计算服务ACS仅发布支持Kubernetes双数号的大版本,例如1.24、1.26、1.28。ACS原则上保持每半年更新一次Kubernetes大版本的频率,大版本推出后,由于功能更新以及漏洞修复,ACS会不定期推出补丁版本的更新。

版本号说明

ACS Kubernetes版本的表达方式为x.y.z-aliyunacs.n。x.y.z表示社区Kubernetes版本,其中,x表示主版本,y表示大版本,z表示补丁版本,n表示阿里云补丁版本。以1.24.6-aliyunacs.1为例,其表示基于Kubernetes 1.24.6版本。关于版本号的详细说明,请参见Kubernetes Release Versioning

版本支持策略

  • 集群创建

    ACS支持创建最近的三个Kubernetes双数大版本的集群。例如,最近的三个双数大版本为1.24、1.26和1.28,当ACS发布支持1.30时,过期大版本1.24将不再开放创建功能,过期补丁版本也不再开放创建功能。

  • 集群升级

    版本升级功能目前仅支持邻近大版本的升级,暂不支持跨多个大版本的升级,不支持回退版本。对于补丁版本,集群升级仅支持最新补丁版本的升级,不支持过期补丁版本的升级。

  • 技术支持

    对于ACS支持的三个Kubernetes双数大版本,ACS提供的技术支持包括答疑、在线指导、排查、排错等工作。

过期版本风险

对于过期版本集群,ACS的策略如下:

  • 停止发布新功能特性

  • 停止修复功能缺陷、安全缺陷

  • 仅提供有限的技术支持

    除集群、组件升级相关问题外,不保证技术支持的时效性。

  • 保留强制升级过期版本集群的权利

    基于集群可用性和安全性的考量,ACS保留强制升级过期版本集群的权利,即强制升级过期集群版本至支持中的最早版本。例如,当您的集群版本为1.24时,ACS支持的集群版本为1.26、1.28、1.30,ACS执行强制升级时会将您的集群升级至1.26版本。

    执行强制升级操作前,ACS会至少提前一个月以短信、邮件、站内信等方式发送相关通知。请关注相关信息并提前规划升级事宜。

上一篇: Kubernetes版本发布记录 下一篇: ACS发布Kubernetes 1.24版本说明