文档

概述

更新时间:

本文介绍云原生多模数据库 Lindorm搜索引擎(Elasticsearch兼容版本)支持的Java客户端以及Client兼容性说明。

客户端简介

Lindorm搜索引擎支持使用以下两种Java客户端访问:

  • Java High Level REST Client(推荐):Elasticsearch官方于2017年9月11日(5.6.0版本)发布的“高级”客户端。 该客户端基于Low Level客户端,并扩展了Low Level Rest客户端的类和接口。Java High Level REST Client依赖于Elasticsearch核心项目,将Request对象作为参数,返回一个Response对象。所有API都可以同步或异步调用。使用方法,请参见Java High Level REST Client

  • Java Low Level REST Client:Elasticsearch官方于2016年发布的“低级”客户端,允许通过HTTP协议与Elasticsearch通信。该客户端的API不负责数据的编码解码,由用户去编码解码。使用方法,请参见Java Low Level REST Client

客户端兼容性说明

REST Client支持向上兼容,例如6.7.0版本的Java High Level REST Client能够与大于等于6.7.0版本的Elasticsearch集群通信。

说明

Lindorm搜索引擎推荐使用7.10.0及以下版本的REST Client。

  • 本页导读 (1)
文档反馈