使用PHP SDK进行日志服务各类操作前,您需要安装PHP SDK。本文介绍PHP SDK的安装方法。

前提条件

  • 已开通日志服务。更多信息,请参见开通日志服务
  • 已创建并获取AccessKey。阿里云账号AccessKey拥有所有API的访问权限,风险很高。强烈建议您创建并使用RAM用户进行API访问或日常运维。更多信息,请参见访问密钥
  • 已安装PHP开发环境。更多信息,请参见PHP官网

    日志服务PHP SDK支持PHP 5.2.1及以上版本。您可以执行php -v命令检查您已安装的PHP版本。

安装PHP SDK

  1. 下载最新的PHP SDK包
  2. 解压aliyun-log-php-sdk-master.zip包到指定目录。
    PHP SDK是一个软件开发包,不需要额外的安装操作。PHP SDK包中除了SDK代码外,还包括一组第三方依赖包和一个Autoloader类,用于简化您的调用流程。

后续步骤

PHP SDK快速入门