建议下载最新发布的SDK版本以获得最佳性能。

前提条件

  1. 您有阿里云开发者账户。
  2. 开通MNS服务
  3. PHP 5.5 及以上版本。

Version 1.3.6

  • 更新日期

    2019-04-26 SDK下载

  • 更新内容

    支持Composer安装。

Version 1.3.5

  • 更新日期

    2017-06-06 SDK下载

  • 更新内容

    在SendMessage的时候对于Priority增加判断。

Version 1.3.4

  • 更新日期

    2017-04-13 SDK下载

  • 更新内容

    支持空变量模板的短信推送。

Version 1.3.3

  • 更新日期

    2016-12-15 SDK下载

  • 更新内容

    支持短信推送,可以查看TopicTest.php里面的对应代码。

Version 1.3.2

  • 更新日期

    2016-11-03 SDK下载

  • 更新内容
    • 增加超时时间设置;
    • GetSubscriptionAttr的response里修复对于Endpoint的解析。

Version 1.3.1

  • 更新日期

    2016-05-19 SDK下载

  • 更新内容

    Samples改进,主要是修改了读取主题消息的HttpServerSample。

Version 1.3.0

  • 更新日期

    2016-02-25 SDK下载

  • 更新内容

    Subscription增加Queue和Mail推送的支持。

  • 运行帮助
    1. 下载并解压SDK到任意目录。
    2. 在使用SDK的文件里加上一行:require_once("/path_to_sdk/mns-autoloader.php")。

Version 1.2.2

  • 更新日期

    2016-02-25 SDK下载

  • 更新内容

    修复了PHP SDK里BatchSendResponse未能正确返回结果的缺陷。

  • 运行帮助
    1. 下载并解压SDK到任意目录。
    2. 在使用SDK的文件里加上一行:require_once("/path_to_sdk/mns-autoloader.php")。

Version 1.2.1

  • 更新日期

    2016-02-22 SDK下载

  • 更新内容

    在PHP SDK里Queue的所有MessageBody都是被默认做了Base64处理。这个版本的队列提供了禁用Base64的选项,需要在getQueueRef 的时候传入参数$base64 = FALSE。

  • 运行帮助
    1. 下载并解压SDK到任意目录。
    2. 在使用SDK的文件里加上一行:require_once("/path_to_sdk/mns-autoloader.php")。

Version 1.2.0

  • 更新日期

    2016-02-14 SDK下载

  • 更新内容

    PublishMessage接口不再对MessageBody做Base64编码。

  • 运行帮助
    1. 下载并解压SDK到任意目录。
    2. 在使用SDK的文件里加上一行:require_once("/path_to_sdk/mns-autoloader.php")。

Version 1.1.0

  • 更新日期

    2016-01-05 SDK下载

  • 更新内容
    • 添加对于主题功能的支持。
    • 添加对于STS Token 的支持。
  • 运行帮助
    1. 下载并解压SDK到任意目录。
    2. 在使用SDK的文件里加上一行:require_once("/path_to_sdk/mns-autoloader.php")。

Version 1.0.0

  • 更新日期

    2015-11-07 SDK下载

  • 运行帮助
    1. 下载并解压SDK到任意目录。
    2. 在使用SDK的文件里加上一行:require_once("/path_to_sdk/mns-autoloader.php")。