在使用内容检测API .NET SDK前,您需要按照以下步骤安装依赖。

环境准备

  • .NET Framework版本为4.5及其以上版本。
  • .NET Standard版本为2.0及其以上版本。
  • C#版本为4.0及其以上版本。

安装SDK

  1. 下载.NET SDK
  2. 安装内容安全.NET SDK。
    • 通过.NET CLI工具安装SDK
      说明 如果您需要安装指定版本,需添加 --version <具体的版本号> ,例如dotnet add package aliyun-net-sdk-core --version 1.0.0。不添加默认安装此软件包的最新版本。
      dotnet add package aliyun-net-sdk-core
      dotnet add package aliyun-net-sdk-green
    • 通过dotnet命令安装
      1. 配置.csproj文件引入依赖包
        <PackageReference Include="aliyun-net-sdk-core" Version="1.5.10" />
        <PackageReference Include="aliyun-net-sdk-green" Version="3.6.5" />
      2. 执行以下命令安装SDK
        dotnet build