无法连接RDS数据库且提示“max_user_connections”相关错误信息
问题描述
通过DMS控制台或者数据库客户端无法连接RDS数据库,且提示“max_user_connections”相关错误信息。
问题原因
RDS数据库的连接数已满,导致不能正常连接。
解决方案
阿里云提醒您:
- 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。
- 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。
- 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。
- 出现该问题后,需要解决RDS连接数被占满的问题:
- 可以在RDS控制台重启数据库来释放连接。
- 若不能在控制台重启,需要手动结束一些RDS连接或者等待RDS自动结束连接,在RDS连接数释放后,再进行登录。
- 如果问题已解决,之后需要优化连接数满的问题,可以参见如何处理RDS MySQL连接数满情况。
适用于
- 云服务器RDS MySQL版