通过阅读本文,您可以了解Web RTS SDK基本信息和浏览器要求。

产品特性

Web RTS SDK是通过HTML网页加载的JavaScript库,不包含普通直播Web推流与播放功能,并且不依赖用户安装App实现直播推流播放。Web RTS SDK只用于RTS低延时直播协议推流与拉流,可以解决在移动端、桌面端和微信上浏览器的推流与播放问题。

浏览器要求

Web RTS SDK视频推流与播放能力不依赖网页代码,而是靠浏览器支持,浏览器具体要求如下所示。更多内容,请参见浏览器兼容性最佳实践

操作系统 浏览器 支持的最低版本 SDK版本要求
Windows Chrome 63 -
Firefox 62 -
Opera 15 -
Edge 79 V2.0.3及以上
QQ浏览器 63(Chrome内核版本) V2.1.0及以上
Mac Chrome 63 -
Safari 11 -
Firefox 62 -
Opera 15 -
Edge 79 V2.0.3及以上
QQ浏览器 63(Chrome内核版本) V2.1.0及以上
Android Chrome 63 -
Edge 79 V2.0.3及以上
微信内置浏览器 7.0.9(微信版本) -
QQ浏览器 63(Chrome内核版本) V2.1.0及以上
华为系统浏览器 63(Chrome内核版本) V2.1.0及以上
OPPO系统浏览器、一加系统浏览器 40.7.39.1(HeyTapBrowser内核版本) V2.1.0及以上
iOS Safari 11 -
Edge 79 V2.0.3及以上
微信内置浏览器 7.0.9(微信版本) -
钉钉内置浏览器 11.2.5(钉钉版本) -
QQ浏览器 11(Safari内核版本) V2.1.0及以上
说明 由于浏览器针对WebRTC安全策略限制,RTS拉流域名需要配置HTTPS证书,否则可能导致直播流无法正常播放。

接口说明

相对于旧版本(V1.1.0~V1.2.4),最新版本Web RTS SDK对接口进行了变更,并且新增RTS推流功能,推荐您使用最新版本的SDK,详情请参见接口说明

如果您需要查看旧版本Web RTS SDK(V1.1.0~V1.2.4)的接口详情,请参见接口说明(旧版:V1.1.0~V1.2.4)

错误码说明

最新版本Web RTS SDK错误码详情请参见错误码说明

如果您需要查看旧版本Web RTS SDK(V1.1.0~V1.2.4)的错误码详情,请参见错误码说明(旧版:V1.1.0~V1.2.4)