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OSS文件处于冻结状态无法正常访问

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问题描述

阿里云对象存储OSS中的文件在以下场景处于冷冻状态,无法正常访问。

  • 文件存储类型是归档存储、冷归档存储或者深度冷归档存储。

  • 文件存在违法违规情况。

问题原因

阿里云对象存储OSS中的文件处于冻结状态有以下几种情况:

  • 在对象存储OSS中,如果Bucket的存储类型是归档存储或者冷归档存储时,默认存放到该Bucket的文件都是冻结状态。

  • 上传文件时设置了文件存储类型为归档存储或者冷归档存储,也会导致文件出现冻结状态。

  • 通过生命周期将其他类型文件转化成归档存储或者冷归档存储后,文件会出现冻结状态。

  • 文件被举报,存在违法违规情况,文件为私有状态。

解决方案

当您的OSS资源处于冻结状态时,请参见以下操作进行排查处理:

  1. 打开消息中心,然后单击安全消息页签,查看是否存在违规通知。

    • 如果因安全原因被冻结,请您到互联网有害信息页面查看涉及违法违规的URL信息,根据系统的提醒,将网站违法文件、违法页面进行彻底整改删除(包括但不限于我们通知的内容)。您需要远程进入您的服务器,根据URL路径找到所有违法的文件并删除。删除违法文件后,您需要申请解除屏蔽。更多信息,请参见申请解除屏蔽

    • 如果不存在违规通知,请继续执行下一步。

  2. 登录对象存储OSS控制台,单击Bucket列表,然后单击目标Bucket名称。选择文件管理>文件列表,查看文件存储类型。如果文件类型为归档存储或冷归档存储类型,请执行以下操作:

    1. 您在访问归档存储或冷归档存储类型的文件(Object)之前,需要先通过RestoreObject接口解冻文件。更多信息,请参见解冻文件。解冻后再将文件转换为标准存储或者低频存储。

      说明
      • 归档存储解冻时间需要1分钟,冷归档存储解冻时间根据数据大小和选择的解冻模式决定。

      • 解冻归档存储和冷归档存储类型文件会产生数据取回费用。更多信息,请参见数据处理费用

    2. 解冻后如需要将文件转换为标准存储或者低频存储,请参见OSS存储类型转换

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