mPaaS 10.1.68 适配 Xcode 13

背景

2022 年 4 月起苹果要求所有提交至 AppStore 的 App 都必须使用 Xcode 13 来构建。针对全新的工具链,需要对 App 进行相关的适配。

现状

目前 mPaaS 已在 10.1.68.47 及以上的基线版中完成了对 Xcode 13 版本的适配和测试工作。

升级 SDK/组件

基于 Extension 插件升级

使用 mPaaS Xcode Extension 插件升级 SDK/组件,您可以选择以下两种方式:

根据自身情况选择升级方式:

  • 已经使用 Extension 插件管理组件依赖,但当前使用的基线版本低于 10.1.68,可使用 升级基线 功能升级至 10.1.68 版本。

    说明

    当前使用的基线版本可在插件的 基线升级 中查看。

  • 已经使用插件管理组件依赖,且当前使用的基线版本为 10.1.68,可使用 更新产品集 功能升级所使用到的模块。

  • 未使用插件管理组件依赖。可按照以下步骤进行升级:

    1. 安装 mPaaS Xcode Extension

    2. 使用 编辑模块 功能选择 10.1.68 版本基线并添加所需模块。

基于 CocoaPods 升级

按照以下步骤,即可安装 10.1.68 版本的最新 SDK:

  1. 首先确保 Podfile 中 mPaaS 组件的版本号为 10.1.68。

  2. 执行 pod mpaas update 10.1.68 命令。如果提示命令报错,需通过 pod mpaas update --all 命令先更新插件,再重新执行。

  3. 执行 pod install 命令 。

API 变更

本次适配暂无接口使用的变化。

定制基线的处理

如果您使用的是定制基线,可能需要基于新版本重新定制,请 提交工单 或联系 mPaaS 支持人员。

适配 Xcode 13 更新的库清单

  • 地图组件升级默认高德地图到 7.1.14 版本。

  • 分享组件。

  • 部分内部依赖组件。

测试验证范围

由于苹果工具链的升级为黑盒操作,经常会带来稳定性等问题,在完成 App 对 Xcode 13 的适配后,建议对 App 进行全面的回归测试。

阿里云首页 移动开发平台 mPaaS 相关技术圈