实例启动异常常见错误与对应解决方案

针对实例启动过程中因操作系统内配置异常、异常关机等问题导致操作系统无法正常启动的情况,您可以通过VNC登录启动异常或者实例健康诊断工具来对应查看本文此类问题的解决方案。

Windows

1662001135:Windows系统因异常进入恢复环境

问题描述

Windows系统实例在较长时间段内正常运行,但是重启后无法进入操作系统。通过VNC登录访问实例时会看到桌面显示系统恢复选项。用户为了正常进入Windows系统使用之前备份的自动快照也无法正常恢复。系统恢复选项

可能原因

Windows系统可能进入了Windows恢复环境。Windows操作系统在遇到异常、无法启动的情况下,会进入恢复环境。操作系统在遇到异常、无法启动可能是由多种原因导致,可能存在的原因如下:

  • 用户注册表损坏、磁盘问题、驱动问题、系统文件损坏或丢失、BCD(Boot Configuration Data)文件损坏等。

  • 用户误操作、病毒、第三方杀毒软件、异常强制重启。

解决方案

针对系统进入修复模式,我们建议采用微软官方技术支持提出的方案进行处理。具体操作,请参见How Windows RE Works

为了避免计算机重启后进入系统恢复界面,确保系统能够从故障中恢复,在日常使用中,可以参考如下内容避免产生故障。

  • 将重要数据放在数据盘。

  • 定期对系统盘、数据盘进行快照,以便发生问题时可以恢复数据。

  • 在修改系统注册表前备份注册表文件,避免修改系统文件。

  • 定期运行Windows Update,确保安装微软最新安全更新。

  • 在ECS中启用云安全中心或其他商业版杀毒防护工具。定期杀毒,定期更新杀毒软件版本。

1662001136:Windows系统的文件系统出现异常

问题描述

用户通过VNC登录实例时,Windows系统启动界面显示内容包含:Checking file system onCHKDSK is verifying filesCHKDSK is verfying indexes

可能原因

导致该问题的可能原因如下:

  • ECS实例异常关机。

  • Windows内部系统损坏。

解决方案

方案一:使用快照恢复系统盘

在存有快照的情况下,您可以使用快照来恢复系统盘的部分数据和配置。具体操作如下:

警告

回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

  1. 登录ECS管理控制台
  2. 在左侧导航栏,选择实例与镜像 > 实例
  3. 在顶部菜单栏左上角处,选择地域。
  4. 找到需要回滚云盘的实例,单击实例ID。
  5. 实例详情页,单击快照页签。
  6. 选择目标快照,在操作列中单击回滚云盘
    说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
  7. 在弹出的对话框中,单击确定
    说明
    • 在单击确定前,建议您单击创建快照备份最新的数据。
    • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

方案二:重置系统盘

您可以重置系统盘来修复系统异常。具体操作如下:

警告

重置系统盘操作会清空云盘已写入数据,建议操作前创建快照备份数据。具体操作,请参见创建一个云盘快照

  1. 停止ECS实例。

    1. 登录ECS管理控制台
    2. 在左侧导航栏,选择实例与镜像 > 实例
    3. 找到需要停止的ECS实例,在操作列,单击icon > 实例状态 > 停止

  2. 重新初始化系统盘。

    1. 找到需要重新初始化系统盘的实例,单击实例ID进入实例详情页。

    2. 单击云盘页签。

    3. 找到系统盘,在操作列中,单击重新初始化云盘

    4. 在弹出的重新初始化云盘对话框里,配置重新初始化参数。

    5. 单击确认重新初始化云盘

      完成重新初始化后,实例会自动启动。重新初始化云盘

1662001137:Windows系统出现内部错误

问题描述

通过VNC登录实例时,Windows启动界面显示内容包含出现内部错误系统找不到指定的文件错误信息。

可能原因

Windows操作系统损坏,导致系统启动失败出现报错。

解决方案

方案一:重启实例

您可以尝试重启实例来修复系统错误。具体操作如下:

  1. 登录ECS管理控制台
  2. 在左侧导航栏,选择实例与镜像 > 实例
  3. 在顶部菜单栏左上角处,选择地域。

  4. 找到需要重启的ECS实例。

    • 如果重启一个实例,在操作列,单击icon > 实例状态 > 重启

    • 如果重启多个实例,选择多个实例(所选实例的状态必须一致),并在页面底部单击三点 > 重启

  5. 重启实例对话框中,选择重启方式,并单击确定

    方案二:使用快照恢复系统盘

    在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

    警告

    回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

    1. 登录ECS管理控制台
    2. 在左侧导航栏,选择实例与镜像 > 实例
    3. 在顶部菜单栏左上角处,选择地域。
    4. 找到需要回滚云盘的实例,单击实例ID。
    5. 实例详情页,单击快照页签。
    6. 选择目标快照,在操作列中单击回滚云盘
      说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
    7. 在弹出的对话框中,单击确定
      说明
      • 在单击确定前,建议您单击创建快照备份最新的数据。
      • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

    方案三:重置系统盘

    您可以重置系统盘来修复系统异常。具体操作如下:

    警告

    重置系统盘操作会清空云盘已写入数据,建议操作前创建快照备份数据。具体操作,请参见创建一个云盘快照

    1. 停止ECS实例。

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 找到需要停止的ECS实例,在操作列,单击icon > 实例状态 > 停止

    2. 重新初始化系统盘。

      1. 找到需要重新初始化系统盘的实例,单击实例ID进入实例详情页。

      2. 单击云盘页签。

      3. 找到系统盘,在操作列中,单击重新初始化云盘

      4. 在弹出的重新初始化云盘对话框里,配置重新初始化参数。

      5. 单击确认重新初始化云盘

        完成重新初始化后,实例会自动启动。重新初始化云盘

      1662001138:Windows系统引导配置数据(BCD)中的文件丢失或损坏

      问题描述

      通过VNC登录实例时,Windows启动界面显示内容包含An error occurred while attempting to read the boot configuration data错误信息。image

      可能原因

      Windows系统引导配置数据(Boot Configuration Data,BCD)配置文件丢失或者损坏。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1662001139:Windows系统的引导扇区或驱动文件丢失或损坏

      问题描述

      通过VNC登录实例时,Windows系统启动显示蓝屏,出现INACCESSIBLE BOOT DEVICE错误信息。image

      可能原因

      可能存在的原因如下:

      • 系统引导扇区丢失或破坏。

      • 系统驱动文件丢失或损坏。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1662001140:Windows系统的Bootmgr配置丢失或损坏

      问题描述

      通过VNC登录实例时,Windows系统启动失败,界面显示内容包含bootmgr is missing错误信息。

      可能原因

      Bootmgr丢失或者破坏,导致系统启动失败。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1662001141:Windows系统的系统文件丢失或损坏

      问题描述

      通过VNC登录实例时,Windows系统启动失败,显示内容包含missing operating system错误信息。

      可能原因

      操作系统文件丢失或者破坏。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1662001142:Windows系统的注册表丢失或者损坏

      问题描述

      通过VNC登录实例时,Windows系统启动失败,VNC控制台显示内容包含Windows未能启动,原因可能是最近更改了硬件或软件错误信息。image

      可能原因

      Windows系统注册表丢失或者破坏,导致系统无法加载。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1662001151:Windows sysprep因实例重启未正常完成,导致操作系统初始化异常

      问题描述

      计算机意外地重新启动或遇到错误,通过VNC登录实例时,界面显示内容包含Windows无法完成安装错误信息。安装Windows

      可能原因

      Sysprep未完成,重启Windows实例导致出现异常。

      解决方案

      警告

      重置系统盘操作会清空云盘已写入数据,建议操作前创建快照备份数据。具体操作,请参见创建一个云盘快照

      1. 停止ECS实例。

        1. 登录ECS管理控制台
        2. 在左侧导航栏,选择实例与镜像 > 实例
        3. 找到需要停止的ECS实例,在操作列,单击icon > 实例状态 > 停止

      2. 重新初始化系统盘。

        1. 找到需要重新初始化系统盘的实例,单击实例ID进入实例详情页。

        2. 单击云盘页签。

        3. 找到系统盘,在操作列中,单击重新初始化云盘

        4. 在弹出的重新初始化云盘对话框里,配置重新初始化参数。

        5. 单击确认重新初始化云盘

          完成重新初始化后,实例会自动启动。重新初始化云盘

      1671696280Windows系统BCD配置异常或磁盘文件系统故障,导致系统启动失败

      问题描述

      通过VNC登录实例时,Windows系统启动失败,VNC控制台显示内容包含Windows未能启动,原因可能是最近更改了硬件或软件错误信息,且状态显示0xc0000001下载

      可能原因

      Windows系统引导配置数据(Boot Configuration Data,BCD)配置异常或者磁盘文件系统故障,导致系统无法加载。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1671696281Windows系统文件损坏或者驱动不兼容,导致系统启动失败

      问题描述

      通过VNC登录实例时,Windows系统启动失败,VNC控制台一直显示选择键盘布局界面。下载 (1)

      可能原因

      Windows系统文件损坏或者驱动不兼容,导致系统无法启动。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1671696282Windows系统磁盘故障或硬件变动,导致系统启动失败

      问题描述

      通过VNC登录实例时,Windows系统启动失败,VNC控制台卡在Windows Error Recovery界面。下载 (2)

      可能原因

      Windows系统磁盘故障或硬件变动,导致系统无法启动。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      1671696284Windows无法找到可用的系统引导启动,导致系统启动失败

      问题描述

      通过VNC登录实例时,Windows启动界面显示内容包含An operating system wasn't found.

      Try disconnecting any drives that don't contain an operating system.错误信息。

      下载 (3)

      可能原因

      Windows系统无法找到可用的系统引导启动,导致系统无法启动。

      解决方案

      使用快照恢复系统盘

      在存有快照的情况下,您可以使用快照来恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      Linux

      1662001143:Linux系统GRUB引导失败

      问题描述

      通过VNC登录实例时,可以看到grub>grub resuce>错误信息,它会导致ECS实例的操作系统启动失败。1143

      可能原因

      grub引导失败进而导致操作系统启动过程无法继续。

      grub引导失败的可能原因有很多种,包括如下原因:

      • grub组件相关文件缺失,比如:/boot/grub2/grub.cfg文件的缺失。

      • grub2内配置不正确或者磁盘上grub2引导已经损坏。

      • 如果在VNC界面有显示类似以下内容的,表示有grub2关键依赖的mod缺失。

        /boot/grubz/i386-pc/normal.mod notfound.

      • 如果在VNC界面有显示类似以下内容的,表示grub2无法识别到对应的分区。

        error:no suchpartition

      • 如果在VNC界面有显示类似以下内容的,表示grub2无法识别所在的分区文件系统类型。

        error:unknown filesystem

      解决方案

      方案一:修复异常ECS实例的数据盘

      1. 卸载异常ECS实例的系统盘,并将该磁盘作为数据盘挂载到正常ECS实例中。

        具体操作,请参见如何恢复系统盘数据?的步骤一~步骤三。

        说明

        本步骤执行完毕,如果您未退出chroot环境,则需要在正常ECS实例上继续执行exit命令退出chroot环境。

      2. 执行如下操作,修复系统盘。

        • 方法一:如果grub2关键依赖的mod缺失或者grub2在磁盘上的信息损坏,您可以在chroot环境中执行grub2-install /dev/vdb命令,重新安装grub2来修复对应问题,操作如下:

          1. 通过磁盘序列号查找对应异常系统盘挂载之后的在OS内的设备名。

            具体操作,请参见查看磁盘序列号,此处以/dev/vdb为例。

          2. 登录正常ECS实例,切换到root用户,依次执行以下命令,进入正常实例的被挂载目录(以/mnt为例)。

            mount -o bind /proc/ /mnt/proc/
            mount -o bind /sys/ /mnt/sys/
            mount -o bind /dev/ /mnt/dev/
            chroot /mnt

          3. 登录正常ECS实例,切换到root用户,依次执行以下命令,进入正常实例的被挂载目录(以/mnt为例)。

          4. 执行grub2-install /dev/vdb命令,重新安装系统盘上的grub。

          5. 在正常ECS实例上输入exit命令,退出chroot。

        • 方法二:在ECS控制台上初始化系统盘,具体操作,请参见重新初始化系统盘

          警告

          重新初始化操作会清空云盘已写入数据,建议操作前创建快照备份数据。创建快照的具体操作,请参见创建一个云盘快照

      3. 在异常ECS实例中恢复挂载系统盘。

        具体操作,请参见如何恢复系统盘数据?的步骤五。

      4. 通过SSH或VNC远程登录已修复的异常ECS实例,确认ECS实例恢复正常。

      方案二:使用快照恢复系统盘

      如果方案一操作之后还是无法恢复系统盘grub2引导实例启动,您可以选择如下方案进行操作:

      如果在您存有快照的情况下,您可以使用快照恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      方案三:重置系统盘

      如果在您系统盘内没有重要数据的情况下,您可以重置系统盘。具体操作如下:

      警告

      重置系统盘操作会清空云盘已写入数据,建议操作前创建快照备份数据。具体操作,请参见创建一个云盘快照

      1. 停止ECS实例。

        1. 登录ECS管理控制台
        2. 在左侧导航栏,选择实例与镜像 > 实例
        3. 找到需要停止的ECS实例,在操作列,单击icon > 实例状态 > 停止

      2. 重新初始化系统盘。

        1. 找到需要重新初始化系统盘的实例,单击实例ID进入实例详情页。

        2. 单击云盘页签。

        3. 找到系统盘,在操作列中,单击重新初始化云盘

        4. 在弹出的重新初始化云盘对话框里,配置重新初始化参数。

        5. 单击确认重新初始化云盘

          完成重新初始化后,实例会自动启动。重新初始化云盘

      1662001144:Linux系统GRUB配置中root根目录的UUID错误

      问题描述

      通过VNC登录实例时,从VNC控制台上可以看到以下日志:

      1144

      可能原因

      在Linux实例启动过程中(dracut-initqueue)界面显示Warning: /dev/disk/by-uuid/10c0e7e5-557a-40c1-893c-1e2dcba***** does not exist一般是因为grub.cfg内配置了UUID设备,可实际对应设备却又不存在所导致的。

      例如:图中配置了root=UUID=10c0e7e5-557a-40c1-893c-1e2dcba*****的UUID设备。

      1144

      解决方案

      1. 卸载异常ECS实例的系统盘,并将该磁盘作为数据盘挂载到正常ECS实例中。

        具体操作,请参见如何恢复系统盘数据?的步骤一~步骤四。

      2. 进入正常实例中,通过磁盘序列号查找对应异常系统盘挂载之后在OS内的设备名。

        具体操作,请参见查看磁盘序列号,此处以/dev/vdb为例。

      3. 通过blkid /dev/vdb1获取到对应的文件系统UUID 。

        /dev/vdb1: UUID="10c0e7e5-557a-40c1-893c-1e2dcba*****" TYPE="ext4"

      4. 修改异常系统盘的grub2.cfg文件内的UUID替换为上述获取到的UUID值。

      5. 恢复异常ECS实例的系统盘。

        具体操作,请参见如何恢复系统盘数据?的步骤五。

      6. 通过SSH或VNC远程登录已修复的ECS实例,确认ECS实例恢复正常。

      1662001145:Linux系统关机时卡住

      问题描述

      ECS实例内部OS启动失败,通过VNC登录实例,界面显示内容包含grub>grub resuce>错误信息,本质是grub引导失败导致OS无法继续启动。

      CentOS release 5.8(Final)
      Kernel 2.6.18-308.el5 on anx 86_64
      iZuf6isbofkgfnm5qp***** login:md:stopping allmddevices.
      System halted.

      可能原因

      系统在关机过程中因未知原因卡住,详细根因需要具体分析系统日志。

      解决方案

      可以尝试通过ECS控制台强制重启实例来修复问题。具体操作如下:

      重要

      强制重启实例时,可能会造成内存中的缓存数据丢失。

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。

      4. 找到需要重启的ECS实例。

        • 如果重启一个实例,在操作列,单击icon > 实例状态 > 重启

        • 如果重启多个实例,选择多个实例(所选实例的状态必须一致),并在页面底部单击三点 > 重启

      5. 重启实例对话框中,选择重启方式,并单击确定

      1662001146:Linux系统/etc/fstab文件中配置的某个挂载点对应的设备不存在

      问题描述

      通过VNC访问实例,发现界面上不断打印出A start job is running错误信息。

      Booting from 0000:7c00
      /: clean, 53966/2621440 files, 648440/10485499 blocks
      A start job is running for dev-xvda1.device (5s / 1min 30s)
      A start job is running for dev-xvda1.device (6s / 1min 30s)
      A start job is running for dev-xvda1.device (7s / 1min 30s)
      ......

      可能原因

      ECS实例内部/etc/fstab配置了不存在的设备挂载点,如下图,实例内部/etc/fstab配置了/dev/xvda1设备实际不存在,则会提示"A start job is running for dev-xvda1.device"

      下载

      解决方案

      1. 等系统检测跑完预定的时间,比如上述是1min30s之后会出现如下界面:

        lQLPJxaJfDVM0TbNAUPNBZmwZt-1jE7qt6gC4lJxSUBjAA_1433_323
      2. 输入密码 ,登录进入OS内部,并执行mount -a命令查看具体报错的行。

      3. 注释或者删除/etc/fstab文件中该行配置后重新启动ECS实例。

        47

      1662001147:Linux系统出现操作系统崩溃

      问题描述

      ECS实例内部OS启动失败,通过VNC访问实例时,可以看到VNC控制台日志有Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block错误信息。

      可能原因

      出现Kernel panic的原因有很多种,可能是内核问题、业务问题或者其他问题。具体错误信息如下:

      • Kernel panic - not syncing fatal exception in interrupt

      • Kernel panic - not syncing: Attempted to kill the idle task!

      • Kernel panic - not syncing: killing interrupt handler!

      • Kernel panic - not syncing: Attempted to kill init!

      解决方案

      您可以根据您的需求选择适合您的解决方案。

      重启ECS实例

      如果您希望快速恢复业务正常使用,则您可以在控制台强制重启实例。具体操作如下:

      重要

      强制重启ECS实例时,可能会造成内存中的缓存数据丢失。

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。

      4. 找到需要重启的ECS实例。

        • 如果重启一个实例,在操作列,单击icon > 实例状态 > 重启

        • 如果重启多个实例,选择多个实例(所选实例的状态必须一致),并在页面底部单击三点 > 重启

      5. 重启实例对话框中,选择重启方式,并单击确定

      1662001148:Linux系统的关键系统文件缺失

      问题描述

      ECS实例内部OS启动失败,通过VNC可以看到类似execute/bin/sh, giving up:No such file or directory的输出。

      0K] Stopped dracut cmdline hook.
      Stopping dracut cmdline hook...
      OK] Stopped Create Static Device Nodes in/dev.
      Stopping Create Static Device Nodes in/dev...
      OK] Stopped Create list of required sta...ce nodes for the current kernel.
      Stopping Create list of required st...nodes for the current kernel...
      OK]ClOSed udev Control Socket.
      OK]ClOSed udev Kernel Socket.
      Starting Cleanup udev dDB.
      [OK] Started Cleanup udev dDB.
      6.573859] system d-journald[106] :Received SIGTERM from PID 1(system d) .
      [DK]Reached target Switch Root.
      [OK] Started Plymouth switch root service.
      Starting Switch Root...
      [6.583367] systemd[1] :No /sbin/init, trying fallback
      [6.584388] systemd[1] :Failed to execute/bin/sh, giving up:No such file or directory
      [892.889761] random:crn gin it done

      可能原因

      ECS实例内部/bin/sh或者/bin/bash文件或者软链被删除,导致实例启动的失败。

      解决方案

      方案一:修复异常ECS实例的数据盘

      1. 卸载异常ECS实例的系统盘,并将该磁盘作为数据盘挂载到正常ECS实例中。

        具体操作,请参见如何恢复系统盘数据?的步骤一~步骤四。

      2. 在正常ECS实例中,将对应的/bin/sh或者/bin/bash文件拷贝到异常ECS系统盘内。

        如将正常ECS实例的/bin/sh拷贝到异常ECS实例(192.168.XXX.XXX)中。

        scp /bin/sh root@192.168.XXX.XXX:/bin/sh

      3. 恢复异常ECS实例的系统盘。

        具体操作,请参见如何恢复系统盘数据?的步骤五。

      4. 通过SSH或VNC远程登录已修复的ECS实例,确认ECS实例恢复正常。

      方案二:使用快照恢复系统盘

      如果方案一操作之后还是无法恢复系统盘grub2引导实例启动,您可以选择如下方案进行操作。

      如果在您存有快照的情况下,您可以使用快照恢复系统盘。具体操作如下:

      警告

      回滚云盘是不可逆操作,从快照的创建日期到回滚云盘时这段时间内的数据会丢失。为避免误操作,建议您在回滚前为云盘创建一份快照备份数据。具体操作,请参见创建一个云盘快照

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      方案三:重置系统盘

      如果您系统盘内没有重要数据的情况下,则您可以重置系统盘。具体操作如下:

      警告

      重置系统盘操作会清空云盘已写入数据,建议操作前创建快照备份数据。具体操作,请参见创建一个云盘快照

      1. 停止ECS实例。

        1. 登录ECS管理控制台
        2. 在左侧导航栏,选择实例与镜像 > 实例
        3. 找到需要停止的ECS实例,在操作列,单击icon > 实例状态 > 停止

      2. 重新初始化系统盘。

        1. 找到需要重新初始化系统盘的实例,单击实例ID进入实例详情页。

        2. 单击云盘页签。

        3. 找到系统盘,在操作列中,单击重新初始化云盘

        4. 在弹出的重新初始化云盘对话框里,配置重新初始化参数。

        5. 单击确认重新初始化云盘

          完成重新初始化后,实例会自动启动。重新初始化云盘

      1662001149:Linux系统启动过程中文件系统fsck检查出异常

      问题描述

      ECS实例启动阶段OS启动卡住,通过VNC登录时,可以看到如下类似输出:

      fsck from util-linux 2.20.1
      fsck from util-linux 2.20.1
      :clean, 193163/ 1310720 files, 2415199/ 5242368 blocks
      /dev/vdb:Superblock last write tine(Tue Nou 2300:31:582021,
      now=WedNou1018:28:552021) is in the future.
      /dev/vdb:UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
      (i.e., without-a or-p options)
      mountall:fsck /data[294] terminated with status 4
      mountall:File system has errors:/data
      Errors were found while checking the disk dr iue for/data.
      Press F to attempt to fix the errors, It oig more, S to skip mounting, or M for

      可能原因

      /data挂载点对应的文件系统存在异常,执行fsck的时候返回报错,需要人工确认是否修复。

      解决方案

      说明

      本解决方案仅针对出现该问题时的修复方案,实际问题中需要根据不同的fsck问题原因,进行不同的修复。

      1. 按照提示输入Press F自动修复。

      2. 如果修复失败,可以再尝试按S跳过对应的/data挂载,继续启动OS。

      3. 在进入OS之后,手动执行fsck检测对应挂载点/data所在的文件系统具体异常。

      1662001150:Linux系统中/etc/fstab文件中配置的某个挂载点对应的设备不存在,或系统启动过程中文件系统fsck检查出异常

      问题描述

      ECS实例内部OS启动卡在Give root password for maintenance等待输入密码页面。如下图:

      lQLPJxaJfDVM0TbNAUPNBZmwZt-1jE7qt6gC4lJxSUBjAA_1433_323

      可能原因

      可能存在的原因如下:

      • Fstab内配置的挂载点对应的设备不存在。

      • 配置了开机fsck自检文件系统,并且fsck发现文件系统存在异常,需要人工参与修复。

      解决方案

      您可以根据实际问题原因来选择适合您的解决方案。

      方案一:修复错误配置

      1. 输入密码进入系统。执行mount -a命令查看具体报错的行。

      2. 在原系统的/etc/fstab文件中,注释或者删除该行配置,之后再重新启动ECS实例。47

      方案二:修复文件系统异常

      输入密码进入系统之后,执行fsck检测的对应的错误,根据实际情况选择对应解决方案进行修复。

      1671696288:Linux系统initrd switch root失败

      问题描述

      Linux系统启动失败。通过VNC查看实例运行状态发现显示类似于Failed to start Switch Root的错误信息。如下图:

      下载 (4)

      可能原因

      Linux系统在启动过程中执行switch root时发生失败的原因可能有很多种,如下:

      方案一:创建缺失文件

      1. 卸载异常ECS实例的系统盘,并将该磁盘作为数据盘挂载到正常ECS实例中。

        具体操作,请参见如何恢复系统盘数据?的步骤一~步骤四。

        说明

        该正常实例最好是与异常实例运行相同的Linux发行版本,以方便后续恢复/etc/os-release文件的操作。

      2. 在正常ECS实例中,根据异常系统盘内是否存在/etc/os-release文件执行相应操作。

        说明

        本示例中,假设异常系统盘中的文件系统挂载到了/mnt目录下。

        可能情况

        具体操作

        /etc/os-release文件不存在

        根据正常ECS实例与异常ECS实例Linux发行版本是否相同,进行相应操作。

        • Linux发行版本相同:执行cp /etc/os-release /mnt/etc/os-release命令将正常实例中的/etc/os-release文件复制到异常ECS实例。

        • Linux发行版本不同:执行vi /mnt/etc/os-release命令手动创建并编辑/etc/os-release文件。/etc/os-release文件的内容参照同一Linux发行版本的正常实例中的/etc/os-release文件内容进行填写。

        说明

        可能会发现参照同一Linux发行版本的正常实例中的/etc/os-release文件是一个指向其它文件的符号链接。您可根据实际情况需要选择一种操作进行修复。

        • 参考上述操作直接恢复包含实际内容的/etc/os-release文件。

          因为/etc/os-release/usr/lib/os-release文件只要其中一个存在即可被systemd正确识别。

        • 参考下述的操作,先恢复/etc/os-release指向的包含实际内容的其它文件,然后再恢复/etc/os-release符号链接,以确保系统文件的完整性和一致性。

        /etc/os-release文件存在

        1. 执行ls -hal /etc/os-release命令。系统返回类似如下信息时,表明/etc/os-release文件是一个指向/usr/lib/os-release的符号链接。

          lrwxrwxrwx 1 root root 19 Dec 20 15:13 os-release -> /usr/lib/os-release
        2. 根据/usr/lib/os-release文件是否缺失,执行相应操作。

          • /usr/lib/os-release文件不存在:

            • Linux发行版本相同:执行cp /usr/lib/os-release /mnt/usr/lib/os-release命令将正常实例中的/usr/lib/os-release文件复制到异常ECS实例。

            • Linux发行版本不同:执行vi /mnt/usr/lib/os-release命令手动创建并编辑/usr/lib/os-release文件。/usr/lib/os-release文件的内容参照同一Linux发行版本的正常实例中的/usr/lib/os-release文件内容进行填写。

          • /usr/lib/os-release文件存在:使用快照恢复系统盘进行修复,具体操作,请参见使用快照回滚云盘

      3. 恢复异常ECS实例的系统盘。

        具体操作,请参见如何恢复系统盘数据?的步骤五。

      4. 通过SSH或VNC远程登录已修复的ECS实例,确认ECS实例恢复正常。

      方案二:使用快照恢复系统盘

      1. 登录ECS管理控制台
      2. 在左侧导航栏,选择实例与镜像 > 实例
      3. 在顶部菜单栏左上角处,选择地域。
      4. 找到需要回滚云盘的实例,单击实例ID。
      5. 实例详情页,单击快照页签。
      6. 选择目标快照,在操作列中单击回滚云盘
        说明 单次只能回滚一块云盘,实例上挂载的其他云盘不受影响。回滚后,整块云盘会恢复到某个时间点的状态,而不是某个分区或目录当时的状态。
      7. 在弹出的对话框中,单击确定
        说明
        • 在单击确定前,建议您单击创建快照备份最新的数据。
        • 如果您选择回滚后立即启动实例,云盘回滚成功后,实例会自动启动。

      阿里云首页 云服务器 ECS 相关技术圈