全部产品
云市场

安装

更新时间:2019-06-24 20:32:32

环境准备

适用于JDK 6及以上版本。

安装SDK

首先添加Maven仓库,然后再加入依赖项。

  • 添加maven仓库
  1. <repositories>
  2. <repository>
  3. <id>sonatype-nexus-staging</id>
  4. <name>Sonatype Nexus Staging</name>
  5. <url>https://oss.sonatype.org/service/local/staging/deploy/maven2/</url>
  6. <releases>
  7. <enabled>true</enabled>
  8. </releases>
  9. <snapshots>
  10. <enabled>true</enabled>
  11. </snapshots>
  12. </repository>
  13. </repositories>
  • 添加Jar包依赖
  1. <dependency>
  2. <groupId>com.aliyun</groupId>
  3. <artifactId>aliyun-java-sdk-core</artifactId>
  4. <version>4.3.3</version>
  5. </dependency>
  6. <dependency>
  7. <groupId>com.aliyun</groupId>
  8. <artifactId>aliyun-java-sdk-vod</artifactId>
  9. <version>2.15.5</version>
  10. </dependency>
  11. <dependency>
  12. <groupId>com.google.code.gson</groupId>
  13. <artifactId>gson</artifactId>
  14. <version>2.8.2</version>
  15. </dependency>

说明:

  • aliyun-java-sdk-core版本>=4.3.3
  • aliyun-java-sdk-vod的版本,请参考 服务端SDK发布历史,首段的Version即为最新的版本号。