全部产品
云市场

安装

更新时间:2019-02-28 20:46:55

环境要求

PHP 5.3+,可通过php -v命令查看当前的PHP版本。若未安装,请到PHP官网下载合适的版本安装。

安装SDK

  1. 在您的PHP项目中添加空文件夹 aliyun-php-sdk(为便于统一管理SDK文件)。

  2. aliyun-openapi-php-sdk 下载整个源码,解压后拷贝 aliyun-php-sdk-corealiyun-php-sdk-vod 两个文件夹到 aliyun-php-sdk 目录下。

建议aliyun-php-sdk-core使用 1.3.8 或以上,aliyun-php-sdk-vod使用 2.15.1 或以上。

更新SDK

若发现当前SDK没有新的接口或已有接口的新的功能,可更新到最新版。再从 aliyun-openapi-php-sdk 下载整个源码,解压后拷贝 aliyun-php-sdk-corealiyun-php-sdk-vod 两个文件夹到 aliyun-php-sdk 目录下,覆盖原有文件。具体方法如下:

  1. 打开aliyun-php-sdk-corealiyun-php-sdk-vod目录下的ChangeLog.txt查看已下载SDK的版本号(首行)。

  2. 下载页面 能看到SDK的最新版本号:php-sdk-corephp-sdk-vod

    以上版本号仅为当前时间示例,请以实际为准。

卸载SDK

直接删除本地SDK目录即可。