调用UpgradeDBInstanceEngineVersion接口升级MongoDB实例的数据库版本。

调用本接口时,要求实例状态为运行中。

说明
  • 实例的存储引擎对数据库版本的选择有约束性,详情请参见版本与存储引擎,您也可以调用DescribeAvailableEngineVersion接口查询实例可升级的版本。
  • 升级数据库版本后不支持降级数据库版本。
  • 升级过程中会自动对实例进行2-3次重启,请确保在业务低峰执行。

调试

您可以在OpenAPI Explorer中直接运行该接口,免去您计算签名的困扰。运行成功后,OpenAPI Explorer可以自动生成SDK代码示例。

请求参数

名称 类型 是否必选 示例值 描述
Action String UpgradeDBInstanceEngineVersion

要执行的操作,取值:UpgradeDBInstanceEngineVersion

EngineVersion String 4.0

升级的目标数据库版本,取值:3.44.0

说明 升级的目标数据库版本必须大于实例当前的数据库版本。
DBInstanceId String dds-bpxxxxxxxx

实例ID。

RegionId String cn-hangzhou

地域ID,您可以调用DescribeRegions查询。

返回数据

名称 类型 示例值 描述
RequestId String C4907B00-A208-4E0C-A636-AA85140E406C

请求ID。

示例

请求示例

http(s)://mongodb.aliyuncs.com/?Action=UpgradeDBInstanceEngineVersion
&EngineVersion=4.0
&DBInstanceId=dds-bpxxxxxxxx
&<公共请求参数>

正常返回示例

XML 格式

<UpgradeDBInstanceEngineVersionResponse>
	  <RequestId>C4907B00-A208-4E0C-A636-AA85140E406C</RequestId>
</UpgradeDBInstanceEngineVersionResponse>

JSON 格式

{
	"RequestId": "C4907B00-A208-4E0C-A636-AA85140E406C"
}

错误码

访问错误中心查看更多错误码。