安装云安全中心的Agent插件后,您的服务器才能受到云安全中心的保护。本文介绍云安全中心Agent的工作原理、相关进程信息和支持的操作系统及内核版本。

工作原理

云安全中心Agent会实时向云安全中心服务器端上报Agent在线信息。

以下两种情况,云安全中心服务器端会判定该服务器不在线,并在云安全中心控制台中将该服务器的客户端状态从已防护图标(在线)变成未防护图标(离线)。
  • 服务端检测到和Agent客户端的通信异常,包括但不限于网络异常、客户端进程被异常结束、客户端被卸载等,会将客户端的状态更改为离线。
  • 如果服务端在10个小时内没有收到Agent客户端登录、采集到的数据等信息,会将客户端状态更改为离线。

Agent进程

云安全中心Agent的进程在Linux系统的服务器上以root账号运行,在Windows系统的服务器上以Administrator账号运行。

下表介绍了Agent插件所包含的文件和核心进程说明。
重要
  • 建议不要在您的服务器中手动删除以下文件或进程,否则可能会导致云安全中心Agent异常。
  • 安装Agent插件后,服务器会自动下载aegis_clientaegis_update文件,并启动进程AliYunDunAliYunDunUpdate。其他的文件和进程只有在您开启相应功能后才会下载和启动。如果您未开启某功能,则无需关注该功能对应的文件和进程。

    例如,在您开启了客户端自保护功能后,云安全中心会在您的服务器中下载AliSecGuard文件,启动相应进程;如果您未开启该功能,则云安全中心不会下载文件,也不会启动相应进程。

云安全中心Agent插件包含的文件 功能说明 文件下载时间 文件所在路径
aegis_client 该目录下核心进程为AliYunDun,用于与云安全中心服务器建立连接。 安装Agent插件后,aegis_client文件会下载到服务器中。
说明 如需删除该文件,请先关闭客户端自保护开关。自保护开关开启时,您将无法卸载Agent或删除Agent的任何进程文件。关闭客户端自保护的具体操作,请参见客户端自保护
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis
aegis_update 该目录下核心进程为AliYunDunUpdate,用于定期检测云安全中心Agent是否需要升级。 安装Agent插件后,aegis_update文件会下载到服务器中。
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis
AliSecGuard 执行攻击防护功能。 开启客户端自保护开关后,AliSecGuard文件会下载到服务器中。关于客户端自保护的更多信息,请参见客户端自保护
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis
AliNet 防护网络侧对服务器发起攻击。 开启恶意网络行为防御开关后,AliNet文件会下载到服务器中。关于恶意网络行为防御的更多信息,请参见主动防御
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis
AliWebGuard 执行网页篡改防护功能。 在购买页开通网页防篡改模块后,AliWebGuard文件会下载到服务器中。
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis
AliHips 执行病毒木马防护功能。 功能设置页面,开启防病毒、防勒索(诱饵捕获)、网站后门连接防御任意一个开关后,AliHips文件会下载到服务器中。
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis
globalcfg 用于存放云安全中心Agent配置文件。 安装Agent插件后,globalcfg文件会下载到服务器中。
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis
PythonLoader 云安全中心基线检查、漏洞修复功能相关进程。核心进程为AliSecureCheck 执行了基线检查或者漏洞检查后,PythonLoader文件会下载到服务器中。
  • Windows 32位系统:C:\Program Files\Alibaba\aegis
  • Windows 64位系统:C:\Program Files (x86)\Alibaba\aegis
  • Linux系统:/usr/local/aegis

Agent支持的操作系统

操作系统类型 支持的操作系统
Windows
  • Windows Server 2019
  • Windows Server 2016
  • Windows Server 2012
  • Windows Server 2008
Linux
  • CentOS 5、6、7、8(64位)
  • Ubuntu 9.10~20.10(64位)
  • Debian 6、7、8、9(64位)
  • RHEL 5、6、7、8(64位)
  • Gentoo(64位)
  • OpenSUSE(64位)
  • SUSE(64位)
  • Aliyun Linux

AliNet支持的操作系统及内核版本

操作系统类型 支操作系统的版本 内核(Kernel)版本
Windows(64位)
  • Windows Server 2008 R2
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019
64位内核
CentOS(64位)
  • CentOS 6.5
  • CentOS 6.6
  • CentOS 6.7
  • CentOS 6.8
  • CentOS 6.9
  • CentOS 6.10
  • CentOS 7.0
  • CentOS 7.1
  • CentOS 7.2
  • CentOS 7.3
  • CentOS 7.4
  • CentOS 7.5
  • CentOS 7.6
  • CentOS 7.7
  • CentOS 7.8
  • CentOS 7.9
  • CentOS 8.0
  • 2.6.32系列
  • 3.10.0系列
  • 4.18.0-147.5.1.el8_1.x86_64
  • 4.18.0-240.15.1.el8_3.x86_64
  • 4.18.0-305.19.1.el8_4.x86_64
  • 4.18.0-348.2.1.el8_5.x86_64
  • 4.18.0-358.el8.x86_64
  • 4.19.104-300.el7.x86_64
  • 5.4.8-1.el7.elrepo.x86_64
  • 5.4.42-200.el7.x86_64
Ubuntu(64位)
  • Ubuntu 14.04
  • Ubuntu 16.04
  • Ubuntu 18.04
  • Ubuntu 20.00
  • 3.13.0-32-generic
  • 3.13.0-86-generic
  • 4.4.0-62-generic
  • 4.4.0-63-generic
  • 4.4.0-93-generic
  • 4.4.0-96-generic
  • 4.4.0-104-generic
  • 4.4.0-117-generic
  • 4.4.0-124-generic
  • 4.4.0-142-generic
  • 4.4.0-146-generic
  • 4.4.0-151-generic
  • 4.4.0-170-generic
  • 4.4.0-174-generic
  • 4.4.0-179-generic
  • 4.4.0-184-generic
  • 4.4.0-185-generic
  • 4.4.0-210-generic
  • 4.15.0-13-generic
  • 4.15.0-23-generic
  • 4.15.0-42-generic
  • 4.15.0-45-generic
  • 4.15.0-52-generic
  • 4.15.0-54-generic
  • 4.15.0-72-generic
  • 4.15.0-96-generic
  • 4.15.0-106-generic
  • 4.15.0-109-generic
  • 4.15.0-111-generic
  • 4.15.0-118-generic
  • 4.15.0-124-generic
  • 4.15.0-128-generic
  • 4.15.0-144-generic
  • 4.15.0-147-generic
  • 4.15.0-158-generic
  • 4.15.0-166-generic
  • 4.15.0-1047-gcp
  • 5.3.0-40-generic
  • 5.4.0-31-generic
  • 5.4.0-42-generic
  • 5.4.0-47-generic
  • 5.4.0-58-generic
  • 5.4.0-73-generic
  • 5.4.0-77-generic
  • 5.4.0-86-generic
  • 5.4.0-91-generic
  • 5.4.0-92-generic
  • 5.4.0-94-generic
Anolis(64位)
  • Anolis 7.9
  • Anolis 8.4
  • 3.10.0-1060.an7.x86_64
  • 3.10.0-1062.an7.x86_64
  • 4.19.91-25.2.an7.x86_64
  • 4.18.0-348.2.1.an8_4.x86_64
AliyunLinux(64位)
  • AliyunLinux 2.1903
  • AliyunLinux 17.01
  • AliyunLinux 3
  • 3.10.0-1160.al7.1.x86_64
  • 4.4.95-1.al7.x86_64
  • 4.4.95-3.al7.x86_64
  • 4.19.24-7.al7.x86_64
  • 4.19.24-7.14.al7.x86_64
  • 4.19.81-17.al7.x86_64
  • 4.19.81-17.2.al7.x86_64
  • 4.19.91-19.1.al7.x86_64
  • 4.19.91-21.2.al7.x86_64
  • 4.19.91-21.al7.x86_64
  • 4.19.91-22.2.al7.x86_64
  • 4.19.91-22.al7.x86_64
  • 4.19.91-23.al7.x86_64
  • 4.19.91-24.1.al7.x86_64
  • 4.19.91-25.1.al7.x86_64
  • 4.19.91-25.3.al7.x86_64
  • 5.10.23-5.al8.x86_64
  • 5.10.60-9.al8.x86_64

AliSecGuard支持的操作系统及内核版本

操作系统类型 操作系统的版本 内核(Kernel)版本
Windows(64位)
  • Windows Server 2008 R2
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019
64位内核
CentOS(64位)
  • CentOS 6.3
  • CentOS 6.4
  • CentOS 6.5
  • CentOS 6.6
  • CentOS 6.7
  • CentOS 6.8
  • CentOS 6.9
  • CentOS 6.10
  • CentOS 7.0
  • CentOS 7.1
  • CentOS 7.2
  • CentOS 7.3
  • CentOS 7.4
  • CentOS 7.5
  • CentOS 7.6
  • CentOS 7.7
  • CentOS 7.8
  • CentOS 7.9
  • CentOS 8.0
  • CentOS 8.1
  • CentOS 8.2
  • CentOS 8.3
  • CentOS 8.4
  • 4.19.104-300.el7.x86_64
  • 4.18.0-305.3.1.el8.x86_64
  • 4.18.0-240.22.1.el8_3.x86_64
  • 4.18.0-240.15.1.el8_3.x86_64
  • 4.18.0-193.28.1.el8_2.x86_64
  • 4.18.0-193.14.2.el8_2.x86_64
  • 4.18.0-193.6.3.el8_2.x86_64
  • 4.18.0-193.el8.x86_64
  • 4.18.0-147.8.1.el8_1.x86_64
  • 4.18.0-147.5.1.el8_1.x86_64
  • 3.10.0-1160.36.2.el7.x86_64
  • 3.10.0-1160.31.1.el7.x86_64
  • 3.10.0-1160.25.1.el7.x86_64
  • 3.10.0-1160.24.1.el7.x86_64
  • 3.10.0-1160.21.1.el7.x86_64
  • 3.10.0-1160.15.2.el7.x86_64
  • 3.10.0-1160.11.1.el7.x86_64
  • 3.10.0-1160.6.1.el7.x86_64
  • 3.10.0-1160.2.2.el7.x86_64
  • 3.10.0-1127.19.1.el7.x86_64
  • 3.10.0-1127.18.2.el7.x86_64
  • 3.10.0-1127.13.1.el7.x86_64
  • 3.10.0-1127.10.1.el7.x86_64
  • 3.10.0-1127.8.2.el7.x86_64
  • 3.10.0-1127.el7.x86_64
  • 3.10.0-1062.18.1.el7.x86_64
  • 3.10.0-1062.12.1.el7.x86_64
  • 3.10.0-1062.9.1.el7.x86_64
  • 3.10.0-1062.4.3.el7.x86_64
  • 3.10.0-1062.4.2.el7.x86_64
  • 3.10.0-1062.4.1.el7.x86_64
  • 3.10.0-1062.1.2.el7.x86_64
  • 3.10.0-1062.1.1.el7.x86_64
  • 3.10.0-1062.el7.x86_64
  • 3.10.0-957.27.2.el7.x86_64
  • 3.10.0-957.21.3.el7.x86_64
  • 3.10.0-957.12.2.el7.x86_64
  • 3.10.0-957.12.1.el7.x86_64
  • 3.10.0-957.10.1.el7.x86_64
  • 3.10.0-957.5.1.el7.x86_64
  • 3.10.0-957.1.3.el7.x86_64
  • 3.10.0-957.el7.x86_64
  • 3.10.0-862.14.4.el7.x86_64
  • 3.10.0-862.11.6.el7.x86_64
  • 3.10.0-862.9.1.el7.x86_64
  • 3.10.0-862.el7.x86_64
  • 3.10.0-693.21.1.el7.x86_64
  • 3.10.0-693.11.1.el7.x86_64
  • 3.10.0-693.5.2.el7.x86_64
  • 3.10.0-693.2.2.el7.x86_64
  • 3.10.0-693.el7.x86_64
  • 3.10.0-514.26.2.el7.x86_64
  • 3.10.0-514.21.1.el7.x86_64
  • 3.10.0-514.10.2.el7.x86_64
  • 3.10.0-514.6.2.el7.x86_64
  • 2.6.32-754.35.1.el6.x86_64
  • 2.6.32-754.33.1.el6.x86_64
  • 2.6.32-754.31.1.el6.x86_64
  • 2.6.32-754.30.2.el6.x86_64
  • 2.6.32-754.29.2.el6.x86_64
  • 2.6.32-754.28.1.el6.x86_64
  • 2.6.32-754.27.1.el6.x86_64
  • 2.6.32-754.25.1.el6.x86_64
  • 2.6.32-754.24.3.el6.x86_64
  • 2.6.32-754.23.1.el6.x86_64
  • 2.6.32-754.18.2.el6.x86_64
  • 2.6.32-754.17.1.el6.x86_64
  • 2.6.32-754.15.3.el6.x86_64
  • 2.6.32-754.11.1.el6.x86_64
  • 2.6.32-696.23.1.el6.x86_64
  • 2.6.32-696.16.1.el6.x86_64
  • 2.6.32-696.10.1.el6.x86_64
  • 2.6.32-696.6.3.el6.x86_64
  • 2.6.32-696.3.2.el6.x86_64
  • 2.6.32-642.15.1.el6.x86_64
  • 2.6.32-642.13.1.el6.x86_64
  • 2.6.32-642.6.2.el6.x86_64
  • 2.6.32-642.el6.x86_64
  • 2.6.32-573.22.1.el6.x86_64
  • 2.6.32-431.23.3.el6.x86_64
  • 2.6.32-431.el6.x86_64
Ubuntu(64位)
  • Ubuntu 14.04
  • Ubuntu 16.04
  • Ubuntu 18.04
  • Ubuntu 20.04
  • 5.4.0-77-generic
  • 5.4.0-74-generic
  • 5.4.0-73-generic
  • 5.4.0-54-generic
  • 5.4.0-47-generic
  • 5.4.0-31-generic
  • 4.15.0-147-generic
  • 4.15.0-144-generic
  • 4.15.0-143-generic
  • 4.15.0-128-generic
  • 4.15.0-124-generic
  • 4.15.0-117-generic
  • 4.15.0-106-generic
  • 4.15.0-91-generic
  • 4.15.0-52-generic
  • 4.15.0-48-generic
  • 4.15.0-45-generic
  • 4.15.0-42-generic
  • 4.4.0-210-generic
  • 4.4.0-179-generic
  • 4.4.0-176-generic
  • 4.4.0-174-generic
  • 4.4.0-170-generic
  • 4.4.0-154-generic
  • 4.4.0-151-generic
  • 4.4.0-146-generic
  • 4.4.0-142-generic
  • 4.4.0-117-generic
  • 4.4.0-105-generic
  • 4.4.0-96-generic
  • 4.4.0-93-generic
  • 4.4.0-63-generic
  • 4.4.0-62-generic
AliyunLinux(64位) AliyunLinux 2.1903
  • 4.19.91-23.al7.x86_64
  • 4.19.91-22.2.al7.x86_64
  • 4.19.91-21.al7.x86_64
  • 4.19.91-19.1.al7.x86_64
  • 4.19.81-17.2.al7.x86_64

AliHips支持的操作系统及内核版本

操作系统类型 操作系统的版本 内核(Kernel)版本
Windows(64位)
  • Windows Server 2008 R2
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019
64位内核
CentOS(64位)
  • CentOS 6.5
  • CentOS 6.6
  • CentOS 6.7
  • CentOS 6.8
  • CentOS 6.9
  • CentOS 6.10
  • CentOS 7.0
  • CentOS 7.1
  • CentOS 7.2
  • CentOS 7.3
  • CentOS 7.4
  • CentOS 7.5
  • CentOS 7.6
  • CentOS 7.7
  • CentOS 7.8
  • CentOS 7.9
  • CentOS 8.0
  • 2.6.32-358.6.2.el6.x86_64
  • 3.10.0-1127.el7.x86_64
  • 2.6.32-431.17.1.el6.x86_64
  • 3.10.0-1160.11.1.el7.x86_64
  • 2.6.32-431.23.3.el6.x86_64
  • 3.10.0-1160.15.2.el7.x86_64
  • 2.6.32-431.el6.x86_64
  • 3.10.0-1160.2.2.el7.x86_64
  • 2.6.32-573.22.1.el6.x86_64
  • 3.10.0-1160.21.1.el7.x86_64
  • 2.6.32-642.1.1.el6.x86_64
  • 3.10.0-1160.24.1.el7.x86_64
  • 2.6.32-642.11.1.el6.centos.plus.x86_64
  • 3.10.0-1160.25.1.el7.x86_64
  • 2.6.32-642.11.1.el6.x86_64
  • 3.10.0-1160.31.1.el7.x86_64
  • 2.6.32-642.13.1.el6.x86_64
  • 3.10.0-1160.36.2.el7.x86_64
  • 2.6.32-642.15.1.el6.x86_64
  • 3.10.0-1160.41.1.el7.x86_64
  • 2.6.32-642.4.2.el6.x86_64
  • 3.10.0-1160.42.2.el7.x86_64
  • 2.6.32-642.6.2.el6.centos.plus.x86_64
  • 3.10.0-1160.45.1.el7.x86_64
  • 2.6.32-642.6.2.el6.x86_64
  • 3.10.0-1160.49.1.el7.x86_64
  • 2.6.32-642.el6.x86_64
  • 3.10.0-1160.53.1.el7.x86_64
  • 2.6.32-696.1.1.el6.x86_64
  • 3.10.0-1160.6.1.el7.x86_64
  • 2.6.32-696.10.1.el6.x86_64
  • 3.10.0-1160.el7.x86_64
  • 2.6.32-696.10.2.el6.x86_64
  • 3.10.0-123.9.3.el7.x86_64
  • 2.6.32-696.13.2.el6.x86_64
  • 3.10.0-229.el7.x86_64
  • 2.6.32-696.16.1.el6.x86_64
  • 3.10.0-327.13.1.el7.x86_64
  • 2.6.32-696.18.7.el6.x86_64
  • 3.10.0-327.22.2.el7.x86_64
  • 2.6.32-696.20.1.el6.x86_64
  • 3.10.0-327.36.3.el7.x86_64
  • 2.6.32-696.23.1.el6.x86_64
  • 3.10.0-327.el7.x86_64
  • 2.6.32-696.3.1.el6.x86_64
  • 3.10.0-514.10.2.el7.x86_64
  • 2.6.32-696.3.2.el6.x86_64
  • 3.10.0-514.16.1.el7.x86_64
  • 2.6.32-696.30.1.el6.x86_64
  • 3.10.0-514.21.1.el7.x86_64
  • 2.6.32-696.6.3.el6.x86_64
  • 3.10.0-514.26.2.el7.x86_64
  • 2.6.32-696.el6.x86_64
  • 3.10.0-514.6.2.el7.x86_64
  • 2.6.32-754.11.1.el6.x86_64
  • 3.10.0-514.el7.x86_64
  • 2.6.32-754.12.1.el6.x86_64
  • 3.10.0-693.11.1.el7.x86_64
  • 2.6.32-754.14.2.el6.x86_64
  • 3.10.0-693.11.6.el7.x86_64
  • 2.6.32-754.15.3.el6.x86_64
  • 3.10.0-693.17.1.el7.x86_64
  • 2.6.32-754.17.1.el6.x86_64
  • 3.10.0-693.2.2.el7.x86_64
  • 2.6.32-754.18.2.el6.x86_64
  • 3.10.0-693.21.1.el7.x86_64
  • 2.6.32-754.2.1.el6.x86_64
  • 3.10.0-693.5.2.el7.x86_64
  • 2.6.32-754.23.1.el6.x86_64
  • 3.10.0-693.el7.x86_64
  • 2.6.32-754.24.3.el6.x86_64
  • 3.10.0-862.11.6.el7.x86_64
  • 2.6.32-754.25.1.el6.x86_64
  • 3.10.0-862.14.4.el7.x86_64
  • 2.6.32-754.27.1.el6.x86_64
  • 3.10.0-862.2.3.el7.x86_64
  • 2.6.32-754.28.1.el6.x86_64
  • 3.10.0-862.3.2.el7.x86_64
  • 2.6.32-754.29.1.el6.x86_64
  • 3.10.0-862.3.3.el7.x86_64
  • 2.6.32-754.29.2.el6.x86_64
  • 3.10.0-862.9.1.el7.x86_64
  • 2.6.32-754.3.5.el6.x86_64
  • 3.10.0-862.el7.x86_64
  • 2.6.32-754.30.2.el6.x86_64
  • 3.10.0-957.1.3.el7.x86_64
  • 2.6.32-754.31.1.el6.x86_64
  • 3.10.0-957.10.1.el7.x86_64
  • 2.6.32-754.33.1.el6.x86_64
  • 3.10.0-957.12.1.el7.x86_64
  • 2.6.32-754.35.1.el6.x86_64
  • 3.10.0-957.12.2.el7.x86_64
  • 2.6.32-754.6.3.el6.x86_64
  • 3.10.0-957.21.2.el7.x86_64
  • 2.6.32-754.9.1.el6.x86_64
  • 3.10.0-957.21.3.el7.x86_64
  • 2.6.32-754.el6.x86_64
  • 3.10.0-957.27.2.el7.x86_64
  • 3.10.0-1062.1.1.el7.x86_64
  • 3.10.0-957.5.1.el7.x86_64
  • 3.10.0-1062.1.2.el7.x86_64
  • 3.10.0-957.el7.x86_64
  • 3.10.0-1062.12.1.el7.x86_64
  • 4.18.0-147.5.1.el8_1.x86_64
  • 3.10.0-1062.18.1.el7.x86_64
  • 4.18.0-147.8.1.el8_1.x86_64
  • 3.10.0-1062.4.1.el7.x86_64
  • 4.18.0-193.14.2.el8_2.x86_64
  • 3.10.0-1062.4.2.el7.x86_64
  • 4.18.0-193.19.1.el8_2.x86_64
  • 3.10.0-1062.4.3.el7.x86_64
  • 4.18.0-193.28.1.el8_2.x86_64
  • 3.10.0-1062.7.1.el7.x86_64
  • 4.18.0-193.6.3.el8_2.x86_64
  • 3.10.0-1062.9.1.el7.x86_64
  • 4.18.0-193.el8.x86_64
  • 3.10.0-1062.el7.x86_64
  • 4.18.0-240.15.1.el8_3.x86_64
  • 3.10.0-1127.10.1.el7.x86_64
  • 4.18.0-240.22.1.el8_3.x86_64
  • 3.10.0-1127.13.1.el7.x86_64
  • 4.18.0-305.3.1.el8.x86_64
  • 3.10.0-1127.18.2.el7.x86_64
  • 4.18.0-80.11.2.el8_0.x86_64
  • 3.10.0-1127.19.1.el7.x86_64
  • 5.4.42-200.el7.x86_64
  • 3.10.0-1127.8.2.el7.x86_64
Ubuntu(64位)
  • Ubuntu 14.04
  • Ubuntu 16.04
  • Ubuntu 18.04
  • Ubuntu 20.00
  • 3.13.0-32-generic
  • 4.15.0-66-generic
  • 4.4.0-177-generic
  • 3.13.0-65-generic
  • 4.15.0-72-generic
  • 4.4.0-179-generic
  • 3.13.0-86-generic
  • 4.15.0-88-generic
  • 4.4.0-184-generic
  • 4.15.0-101-generic
  • 4.15.0-91-generic
  • 4.4.0-62-generic
  • 4.15.0-106-generic
  • 4.15.0-96-generic
  • 4.4.0-63-generic
  • 4.15.0-109-generic
  • 4.4.0-104-generic
  • 4.4.0-93-generic
  • 4.15.0-118-generic
  • 4.4.0-117-generic
  • 4.4.0-96-generic
  • 4.15.0-143-generic
  • 4.4.0-124-generic
  • 5.4.0-31-generic
  • 4.15.0-23-generic
  • 4.4.0-142-generic
  • 5.4.0-42-generic
  • 4.15.0-42-generic
  • 4.4.0-146-generic
  • 5.4.0-47-generic
  • 4.15.0-45-generic
  • 4.4.0-151-generic
  • 5.4.0-65-generic
  • 4.15.0-48-generic
  • 4.4.0-170-generic
  • 5.4.0-74-generic
  • 4.15.0-52-generic
  • 4.4.0-174-generic
  • 5.4.0-77-generic
  • 4.15.0-54-generic
  • 4.4.0-176-generic
AliyunLinux(64位)
  • AliyunLinux 2.1903
  • AliyunLinux 17.01,3
  • AliyunLinux 3
  • 4.19.24-7.14.al7.x86_64
  • 4.19.91-24.1.al7.x86_64
  • 4.19.24-7.al7.x86_64
  • 4.19.91-24.al7.x86_64
  • 4.19.81-17.2.al7.x86_64
  • 4.4.95-1.al7.x86_64
  • 4.19.81-17.al7.x86_64
  • 4.4.95-3.al7.x86_64
  • 4.19.91-18.al7.x86_64
  • 4.9.151-015.ali3000.alios7.x86_64
  • 4.19.91-19.1.al7.x86_64
  • 4.9.168-019.ali3000.alios7.x86_64
  • 4.19.91-21.al7.x86_64
  • 5.10.23-5.al8.x86_64
  • 4.19.91-22.2.al7.x86_64
  • 5.10.23-6.1.al8.x86_64
  • 4.19.91-22.al7.x86_64
  • 5.10.23-6.al8.x86_64
  • 4.19.91-23.al7.x86_64

AliWebGuard支持的操作系统及内核版本

表 1. 操作系统和内核版本限制
操作系统 操作系统版本号 内核版本号
Windows(32位或64位) Windows Server 2008、2012、2016和2019 所有版本
CentOS(64位)
  • CentOS 6.3
  • CentOS 6.5
  • CentOS 6.6
  • CentOS 6.7
  • CentOS 6.8
  • CentOS 6.9
  • CentOS 6.10
  • CentOS 7.0-1406
  • CentOS 7.1-1503
  • CentOS 7.2-1511
  • CentOS 7.3-1611
  • CentOS 7.4-1708
  • CentOS 7.5-1804
  • CentOS 7.6-1810
  • CentOS 7.7-1908
  • CentOS 7.8-2003
  • CentOS 7.9-2009
  • 2.6.32-**(表示所有2.6.32版本的CentOS系统内核)
  • 3.10.0-**(表示所有3.10.0版本的CentOS系统内核)
  • CentOS 8.0-1905
  • CentOS 8.1-1911
  • CentOS 8.2-2004
  • CentOS 8.3-2011
  • CentOS 8.4-2105
  • CentOS 8.5
  • CentOS Stream 8
  • 4.18.0-80.11.2.el8_0.x86_64
  • 4.18.0-147.3.1.el8_1.x86_64
  • 4.18.0-147.5.1.el8_1.x86_64
  • 4.18.0-147.8.1.el8_1.x86_64
  • 4.18.0-193.el8.x86_64
  • 4.18.0-193.6.3.el8_2.x86_64
  • 4.18.0-193.14.2.el8_2.x86_64
  • 4.18.0-193.28.1.el8_2.x86_64
  • 4.18.0-240.1.1.el8_3.x86_64
  • 4.18.0-240.15.1.el8_3.x86_64
  • 4.18.0-240.22.1.el8_3.x86_64
  • 4.18.0-305.3.1.el8.x86_64
  • 4.18.0-305.7.1.el8_4.x86_64
  • 4.18.0-305.10.2.el8_4.x86_64
  • 4.18.0-305.12.1.el8_4.x86_64
  • 4.18.0-305.19.1.el8_4.x86_64
  • 4.18.0-305.25.1.el8_4.x86_64
  • 4.18.0-348.2.1.el8_5.x86_64
  • 4.18.0-348.7.1.el8_5.x86_64
  • 4.18.0-358.el8.x86_64
  • 4.18.0-365.el8.x86_64
Ubuntu(64位) Ubuntu 14.04
  • 3.13.0-32-generic
  • 3.13.0-65-generic
  • 3.13.0-86-generic
  • 3.13.0-145-generic
  • 3.13.0-164-generic
  • 3.13.0-170-generic
  • 3.19.0-80-generic
  • 4.4.0-93-generic
Ubuntu 16.04
  • 4.4.0-62-generic
  • 4.4.0-63-generic
  • 4.4.0-79-generic
  • 4.4.0-93-generic
  • 4.4.0-96-generic
  • 4.4.0-104-generic
  • 4.4.0-117-generic
  • 4.4.0-124-generic
  • 4.4.0-142-generic
  • 4.4.0-146-generic
  • 4.4.0-151-generic
  • 4.4.0-154-generic
  • 4.4.0-157-generic
  • 4.4.0-161-generic
  • 4.4.0-170-generic
  • 4.4.0-174-generic
  • 4.4.0-176-generic
  • 4.4.0-177-generic
  • 4.4.0-178-generic
  • 4.4.0-179-generic
  • 4.4.0-184-generic
  • 4.4.0-194-generic
  • 4.4.0-198-generic
  • 4.4.0-210-generic
Ubuntu 18.04
  • 4.15.0-23-generic
  • 4.15.0-42-generic
  • 4.15.0-45-generic
  • 4.15.0-48-generic
  • 4.15.0-52-generic
  • 4.15.0-54-generic
  • 4.15.0-66-generic
  • 4.15.0-70-generic
  • 4.15.0-72-generic
  • 4.15.0-88-generic
  • 4.15.0-91-generic
  • 4.15.0-96-generic
  • 4.15.0-101-generic
  • 4.15.0-106-generic
  • 4.15.0-109-generic
  • 4.15.0-112-generic
  • 4.15.0-117-generic
  • 4.15.0-118-generic
  • 4.15.0-121-generic
  • 4.15.0-122-generic
  • 4.15.0-124-generic
  • 4.15.0-128-generic
  • 4.15.0-143-generic
  • 4.15.0-151-generic
  • 4.15.0-162-generic
  • 4.15.0-166-generic
  • 4.15.0-169-generic
  • 4.15.0-170-generic
  • 4.15.0-173-generic
  • 4.15.0-175-generic
  • 4.15.0-177-generic
  • 4.15.0-181-generic
  • 4.15.0-189-generic
  • 4.15.0-190-generic
  • 4.15.0-192-generic
Ubuntu 20.04
  • 5.4.0-47-generic
  • 5.4.0-70-generic
  • 5.4.0-77-generic
  • 5.4.0-86-generic
  • 5.4.0-90-generic
  • 5.4.0-92-generic
  • 5.4.0-94-generic
  • 5.4.0-100-generic
  • 5.4.0-102-generic
  • 5.4.0-106-generic
  • 5.4.0-108-generic
  • 5.4.0-110-generic
  • 5.4.0-113-generic
  • 5.4.0-122-generic
  • 5.4.0-123-generic
  • 5.4.0-125-generic
Anolis OS(64位)
  • Anolis OS 7.9 RHCK
  • Anolis OS 7.9 ANCK
  • Anolis OS 8.4 RHCK
  • 3.10.0-1062.an7.x86_64
  • 3.10.0-1160.an7.x86_64
  • 3.10.0-1160.59.1.0.1.an7.x86_64
  • 3.10.0-1160.62.1.0.1.an7.x86_64
  • 3.10.0-1160.66.1.0.1.an7.x86_64
  • 3.10.0-1160.71.1.0.1.an7.x86_64
  • 4.18.0-348.2.1.an8_4.x86_64
  • 4.18.0-348.12.2.an8.x86_64
  • 4.18.0-348.20.1.an8_5.x86_64
  • 4.18.0-348.23.1.an8_5.x86_64
  • 4.18.0-372.9.1.an8.x86_64
  • 4.18.0-372.16.1.an8_6.x86_64
  • 4.18.0-372.19.1.an8_6.x86_64
  • 4.19.91-25.2.an7.x86_64
  • 4.19.91-25.7.an7.x86_64
  • 4.19.91-25.7.an8.x86_64
  • 4.19.91-25.8.an8.x86_64
  • 4.19.91-26.an7.x86_64
  • 4.19.91-26.an8.x86_64
  • 4.19.91-26.1.an8.x86_64
RHEL
  • RHEL 6.2
  • RHEL 7.7
  • RHEL 7.8
  • RHEL 7.9
  • RHEL 8.0
  • 2.6.32-220
  • 3.10.0-1062
  • 3.10.0-1127
  • 3.10.0-1160
  • 4.18.0-80
AliyunOS(64位)
  • Alibaba Cloud Linux 2.1903
  • Alibaba Cloud Linux 3.2104
  • 4.4.95-1.al7.x86_64
  • 4.4.95-2.al7.x86_64
  • 4.4.95-3.al7.x86_64
  • 4.19.24-7.al7.x86_64
  • 4.19.24-7.14.al7.x86_64
  • 4.19.81-17.al7.x86_64
  • 4.19.81-17.2.al7.x86_64
  • 4.19.91-18.al7.x86_64
  • 4.19.91-19.1.al7.x86_64
  • 4.19.91-21.al7.x86_64
  • 4.19.91-22.2.al7.x86_64
  • 4.19.91-23.al7.x86_64
  • 4.19.91-24.al7.x86_64
  • 4.19.91-24.1.al7.x86_64
  • 4.19.91-25.1.al7.x86_64
  • 4.19.91-25.3.al7.x86_64
  • 4.19.91-25.6.al7.x86_64
  • 4.19.91-25.7.al7.x86_64
  • 4.19.91-25.8.al7.x86_64
  • 4.19.91-26.al7.x86_64
  • 4.19.91-26.1.al7.x86_64
  • 5.10.23-5.al8.x86_64
  • 5.10.60-9.al8.x86_64
  • 5.10.84-10.2.al8.x86_64
  • 5.10.84-10.3.al8.x86_64
  • 5.10.84-10.4.al8.x86_64
  • 5.10.112-11.al8.x86_64
  • 5.10.112-11.1.al8.x86_64
  • 5.10.112-11.2.al8.x86_64
  • 5.10.134-12.al8.x86_64

服务器防勒索支持的操作系统版本

重要 服务器防勒索仅支持在以下表格中的操作系统安装防勒索客户端,不在以下表格中的操作系统将无法安装防勒索客户端并进行数据备份。建议您在使用防勒索功能前,先确认您服务器的操作系统是否在以上支持范围内。
系统 支持的版本
Windows 7、8、10
Windows Server 2008 R2、2012、2012 R2、2016、2019
RHEL 7.0、7.2、7.4、7.5、7.6、7.7、7.8、8.0、8.1、8.2
CentOS 6.5、6.9、7.2、7.3、7.4、7.5、7.6、7.7、7.8、7.9、8.2、8.3
Ubuntu 14.04、16.04、18.04、20.04
SUSE Linux Enterprise Server 11、12、15

数据库防勒索支持的数据库版本和操作系统版本

重要 数据库防勒索仅支持在以下表格中的数据库以及操作系统安装防勒索客户端,不在以下表格中的数据库及操作系统将无法安装防勒索客户端并进行数据备份。建议您在使用防勒索功能前,先确认您服务器的操作系统版本、数据库版本是否在以下支持范围内。
数据库类型 支持的数据库的版本 支持的操作系统的版本
Oracle 9i SUSE 9.3、RHEL 4、RHEL 5、SLES 9、CentOS 4.5
10g RHEL 9、RHEL 4、RHEL 5、CentOS 4.6、SUSE 11 SP4、RHEL 6.5
11g RHEL 5、RHEL 6、CentOs 6.4、RHEL 6.5、CentOS 6.5、Oracle Enterprise Linux6.7、RHEL 7、Windows 2008 R2、Windows 2012 R2、RHEL 6.0
12c Windows 2008 R2、RHEL 6.5、RHEL 6.5、RHEL 7.5
18c RHEL 7.0、Windows 2008 R2
19c Oracle Enterprise Linux7.0
Oracle RAC 9i SUSE 9.3、RHEL
10g RHEL 5、Windows 2008 R2
11g Windows 2008 R2、RHEL 5、Oracle Linux 6.4、RHEL 6.5、iSoft Server 3.0
12c CentOS 6、RHEL 6.5、Windows 2008 R2、CentOS 6.7、Oracle Enterprise Linux6
18c Windows 2008 R2
19c RHEL 7.6
Oracle Data Guard 11g CentOS 6.4、CentOS 6.5、RHEL 6、Windows 2008 R2
12c Oracle Enterprise Linux6
MySQL 5.0 RHEL 5.0、RHEL 6.0 、RHEL 6.5 、Ubuntu 12.10、SLES 10、SUSE 11 SP4、Ubuntu 11.10、Neokylin 6.0
5.1 RHEL 6.5、SUSE 11 SP4、RHEL 6.5、RHEL 6.0
5.4 RHEL 6.5、SUSE 11 SP4
5.5 Ubuntu 12.04、Ubuntu 14.04、Debian 7.8、Debian 8.3 、CentOS 6.0、RHEL 6.5
5.6 RHEL 5.0、RHEL 6.0、RHEL 6.5、Ubuntu 14.04 、CentOS 6.0、CentOS 7.2
5.7 RHEL 6.0、RHEL 7.0 、CentOS 7.0、RHEL 6.5、Ubuntu 16.04、CentOS 7.2、RHEL 7.0、Neokylin 7.0
SQL Server 2005 Windows 2008 R2 SP1
2008 Windows 2008 R2、Windows 2008 R2 SP1
2008 R2 Windows 2008 R2
2012 Windows 2012 RC
2014 Windows 2008 R2 SP1、Windows 2016
2016(RTM) Windows 2012 R2
2017 Windows 2012、Windows 2016
2019 Windows 2016
SQL Server Always On 2012、2016、2017 Windows 2012 R2