• E-MapReduce 的版本会定期升级,类似 1.0、1.1、1.2。
  • 每一个版本上捆绑的软件和软件的版本都是固定的。目前还不支持软件的多个不同版本的选择,也不推荐用户自行更改软件的版本。例如我们在 1.0 中内置的是 Hadoop 2.6.0,Spark 1.4.1等。
  • 一旦选择了某个版本,并创建了集群,该集群使用的版本就不会自动升级了,例如 1.0版本,那么 Hadoop 就一直保持在 2.6.0,Spark 就一直保持在 1.4.1。后续如果版本升级到了 1.1,Hadoop 到了 2.7.0,Spark 到了 1.5.0 也不会影响到已经创建出来的集群。只有新的集群才会使用新的镜像。
  • 当您升级集群版本的时候,比如从 1.0 升级到 1.1,防止一些升级的不兼容,环境的变化等,请务必测试您的作业,保证他们在新的软件环境中也能正常的运行。