当您在SAE上进行应用部署、启动、扩容/缩容等生命周期操作后,可以跳转到应用详情页查看当前变更状态,也可以通过变更记录页面查看该应用的历史变更记录。

操作指南

  1. 登录SAE控制台
  2. 在左侧导航栏,选择应用管理 > 应用列表,在顶部菜单栏选择地域,然后单击具体应用名称。
  3. 在左侧导航栏,单击变更记录,查看该应用的所有变更操作以及该操作的变更状态。
    说明 在执行完应用变更操作后,在应用基本信息页面上方出现变更提示应用有变更流程正在执行,处于执行中状态,您可以单击查看详情阅览该应用的变更信息及实时状态。
    查看变更记录
  4. 在操作列单击查看,查阅变更详情及操作的详细信息。
    变更详情

    该页面包含变更概要信息和变更流程执行信息。

    • 变更概要信息:包括变更流程ID、执行状态、变更类型等信息。
    • 变更流程执行信息:包含整个变更流程,以及变更阶段中具体的变更任务。
  5. 在变更流程执行信息区域的右侧展开具体任务,可以查看该变更过程中本环节的操作日志。
    如果流程中出现失败任务,系统自动展开日志,请排查任务失败原因。更多信息,请参见常见问题

常见问题

如果应用的变更记录中出现失败记录,您可以在变更详情中查询变更流程中哪些步骤执行失败,以及失败的原因。

排查变更失败问题

  1. 在应用基本信息页面左侧的导航栏,单击变更记录
    查看变更记录列表

    如果变更失败,则在变更状态列会显示执行失败

  2. 在执行失败的变更记录所在行,单击查看
  3. 变更详情页签,在变更区域单击失败的阶段,例如部署应用,在右侧实例中查看失败步骤的具体日志,定位问题。
    查看执行失败的变更记录

应用变更典型异常及处理

端口健康检查异常导致变更失败

端口健康检查导致变更失败
  • 可能原因
    • 应用启动时应该被正常占用的65000端口不可访问。
    • 客户的Tomcat容器没有正常启动。
  • 处理方法

    查看应用日志是否有相应的异常日志。