Create and manage a knowledge base

更新时间: 2026-01-18 19:04:14

A knowledge base helps you compile solutions to common or specific data quality issues to improve the efficiency of issue resolution. This topic describes how to create and manage a knowledge base.

Permissions

  • All members can create and view knowledge bases, and associate them with quality rules. Super administrators and quality administrators can edit and delete all knowledge bases. Knowledge base owners can edit and delete the knowledge bases they own.

  • Quality administrators can add or remove quality rules associated with any knowledge base. Knowledge base owners can only add or remove quality rules associated with the knowledge bases they own.

  • Operation permissions vary by object. For more information, see and Administration whitelist operation permissions.

Create a knowledge base

  1. On the Dataphin home page, choose Administration > Data Quality from the top menu bar.

  2. In the navigation pane on the left, choose Governance Workbench > Knowledge Base. On the Knowledge Base page, click the Create Knowledge Base Document button.

  3. In the Create Knowledge Base panel, configure the parameters.

    Parameter

    Description

    Basic information

    Title

    The title of the knowledge base. The title can be up to 128 characters long.

    Description

    A custom description. Describe the purpose of the knowledge base based on your business scenario. The description can be up to 512 characters long.

    Owner

    Select an owner for the knowledge base.

    Problem cause

    A detailed description of the problem. For example: The information entered for a new employee contains null values. The description can be up to 1,024 characters long.

    Solution

    A description of the solution. For example: Export the employee information table that contains issues. After the HR manager fills in the missing information, the IT department re-uploads the modified table. The description can be up to 1,024 characters long.

    Related objects

    Related quality rules

    Click the Add Related Rules button. In the dialog box that appears, filter quality rules by monitored object type and monitored object.

    image.png

    Related files

    Click the Upload Related Files button. In the dialog box that appears, upload files.

    image.png

    Note
    • You can upload files from your local computer. File names must be unique.

    • A knowledge base can have a maximum of 10 files. Each file can be up to 10 MB.

    • Supported file formats: Word (.doc, .docx, .dot, .dotx, .rtf, .html, .xml, .txt), Excel (.xls, .xlsx, .csv), PDF (.pdf), and Image (.jpg, .png, .jpeg).

  4. Click OK to create the knowledge base.

View a knowledge base

After you create a knowledge base, you can view, edit, or delete it on the knowledge base page.

image

Area

Description

① Search area

Search for a knowledge base by its title or a keyword in its description.

② List area

Displays the title, owner, and description of each knowledge base.

③ Operations area

View, edit, or delete a knowledge base.

  • View: View the details of the knowledge base. The details include document information and edit history. To modify the knowledge base, click the Edit button at the bottom.

    • Document Information: Displays the basic information of the knowledge base and details of related objects. Click Related quality rules to view the details of monitored objects. Click Related files to view the details of uploaded files. You can also search for related quality rules and search for or download related files.

      • Related quality rules: Filter related monitored objects by type. You can also perform a fuzzy search by the name of the monitored object, validation object, or quality rule.

      • Related files: Search for files by name. You can also click the download icon in the Actions column to download a single file, or click the download icon at the bottom to download files in a batch.

        image.png

    • Edit History: Displays the edit history of the knowledge base, including the Operator, Time, Operation Type, and Operation Details.

  • Edit: Modify the basic information of the knowledge base, disassociate related quality rules, or delete uploaded files. After you save the changes, the updated information is displayed in Data Quality and Governance Workbench.

    • Related quality rules: Click the disassociate icon in the Actions column to remove the association for a single monitored object. You can also click the disassociate icon at the bottom to remove associations in a batch.

      Note

      After a quality rule is disassociated, its association in the knowledge base is automatically removed.

    • Related files: Click the delete icon in the Actions column to delete a single file. You can also click the delete icon at the bottom to delete files in a batch. This operation cannot be undone. Proceed with caution.

  • Delete: When you delete a knowledge base, all its associations are also deleted. This operation cannot be undone. Proceed with caution.

What to do next

After you associate a knowledge base with quality rules and the Governance Workbench, you can view the associated knowledge base in the Data Quality and Governance Workbench modules. For more information, see the following topics:

上一篇: View and manage remediation processes 下一篇: View and manage governance ignore lists
阿里云首页 智能数据建设与治理 Dataphin 相关技术圈