Create and manage a knowledge base
A knowledge base helps you compile solutions to common or specific data quality issues to improve the efficiency of issue resolution. This topic describes how to create and manage a knowledge base.
Permissions
All members can create and view knowledge bases, and associate them with quality rules. Super administrators and quality administrators can edit and delete all knowledge bases. Knowledge base owners can edit and delete the knowledge bases they own.
Quality administrators can add or remove quality rules associated with any knowledge base. Knowledge base owners can only add or remove quality rules associated with the knowledge bases they own.
Operation permissions vary by object. For more information, see and Administration whitelist operation permissions.
Create a knowledge base
On the Dataphin home page, choose Administration > Data Quality from the top menu bar.
In the navigation pane on the left, choose Governance Workbench > Knowledge Base. On the Knowledge Base page, click the Create Knowledge Base Document button.
In the Create Knowledge Base panel, configure the parameters.
Parameter
Description
Basic information
Title
The title of the knowledge base. The title can be up to 128 characters long.
Description
A custom description. Describe the purpose of the knowledge base based on your business scenario. The description can be up to 512 characters long.
Owner
Select an owner for the knowledge base.
Problem cause
A detailed description of the problem. For example: The information entered for a new employee contains null values. The description can be up to 1,024 characters long.
Solution
A description of the solution. For example: Export the employee information table that contains issues. After the HR manager fills in the missing information, the IT department re-uploads the modified table. The description can be up to 1,024 characters long.
Related objects
Related quality rules
Click the Add Related Rules button. In the dialog box that appears, filter quality rules by monitored object type and monitored object.

Related files
Click the Upload Related Files button. In the dialog box that appears, upload files.
NoteYou can upload files from your local computer. File names must be unique.
A knowledge base can have a maximum of 10 files. Each file can be up to 10 MB.
Supported file formats: Word (.doc, .docx, .dot, .dotx, .rtf, .html, .xml, .txt), Excel (.xls, .xlsx, .csv), PDF (.pdf), and Image (.jpg, .png, .jpeg).
Click OK to create the knowledge base.
View a knowledge base
After you create a knowledge base, you can view, edit, or delete it on the knowledge base page.

Area | Description |
① Search area | Search for a knowledge base by its title or a keyword in its description. |
② List area | Displays the title, owner, and description of each knowledge base. |
③ Operations area | View, edit, or delete a knowledge base.
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What to do next
After you associate a knowledge base with quality rules and the Governance Workbench, you can view the associated knowledge base in the Data Quality and Governance Workbench modules. For more information, see the following topics:
