Create and manage knowledge base

更新时间: 2026-06-23 10:19:49

A knowledge base consolidates solutions for specific quality issues or categories of issues to improve problem-solving efficiency.

Permission description

  • All members can create, view, and associate quality rules with knowledge bases. Super administrators and quality administrators can edit and delete any knowledge base. Knowledge base owners can edit and delete the knowledge bases they manage.

  • Quality administrators can add or remove quality rules for any knowledge base. Knowledge base owners can only manage quality rules for the knowledge bases they oversee.

  • Operation permissions vary for different objects. For more information, see .

Create a knowledge base

  1. On the Dataphin home page, select Administration > Data Quality from the top menu bar.

  2. In the left-side navigation pane, choose Governance Workbench > Knowledge Base. On the Knowledge Base page, click the Create Knowledge Base Document button.

  3. In the Create Knowledge Base panel, enter the required parameters.

    Parameter

    Description

    Basic Information

    Title

    The title of the knowledge base, up to 128 characters.

    Description

    A custom description of the knowledge base. We recommend that you explain its purpose based on the business scenario. Up to 512 characters.

    Owner

    Select the owner of the current knowledge base.

    Problem Cause

    The details of the problem. Example: Employee onboarding information contains empty values. Up to 1024 characters.

    Solution

    The solution to the problem. Example: Export the problematic employee information table. After the HR owner completes the information, the IT department uploads the revised table. Up to 1024 characters.

    Related Objects

    Related Quality Rules

    Click Add Related Rules. In the Add Related Rules dialog box, filter quality rules by monitored object type and monitored object.

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    Related Files

    Click Upload Related Files. In the Upload Related Files dialog box, upload files.

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    Note
    • You can select files from local storage to upload. File names must be unique.

    • Each knowledge base can contain up to 10 files, with each file no larger than 10 MB.

    • Supported file formats include the following: Word (.doc, .docx, .dot, .dotx, .rtf, .html, .xml, .txt), Excel (.xls, .xlsx, .csv), PDF (.pdf), and Images (.jpg, .png, .jpeg).

  4. Click OK to finalize the knowledge base creation.

View the knowledge base

After creating a knowledge base, you can view, edit, or delete it on the Knowledge Base page.

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Area

Description

① Search Area

Search for knowledge bases by title or description keywords.

② List Area

Displays the title, owner, and description of the knowledge base.

③ Operation Area

You can view, edit, or delete the knowledge base.

  • View: View knowledge base details, including document information and edit history. To modify the knowledge base, click Edit at the bottom.

    • Document Information: Displays basic information and related object details. Click Related Quality Rules to view monitored object details. Click Related Files to view uploaded file details. You can also search for related quality rules or search and download related files.

      • Related Quality Rules: Filter related monitored objects by type. You can also perform fuzzy searches by monitored object, validation object, or quality rule name.

      • Related Files: Search files by name. You can click the download icon in the operation column to download a single file or click the download icon at the bottom to batch download files.

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    • Edit History: Displays the edit history of the knowledge base, including Operator, Operation Time, Operation Type, and Operation Details.

  • Edit: Modify basic information, disassociate related quality rules, or delete uploaded files. After you save changes, the quality rules and governance workbench display the updated information.

    • Related Quality Rules: Click the disassociate icon in the operation column to remove the association of a single monitored object. You can also click the disassociate icon at the bottom to batch remove associations.

      Note

      After disassociating related quality rules, the associations in the knowledge base will be automatically removed.

    • Related Files: Click the delete icon in the operation column to delete a single file. You can also click the delete icon at the bottom to batch delete files. Deletion is irreversible, so proceed with caution.

  • Delete: Deletes the knowledge base and automatically removes all associated relationships. Proceed with caution.

What to do next

After a knowledge base is linked with quality rules and the governance workbench, you can view the associated knowledge base in these areas. For more information, see

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