Create and manage knowledge base
A knowledge base consolidates solutions for specific quality issues or categories of issues to improve problem-solving efficiency.
Permission description
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All members can create, view, and associate quality rules with knowledge bases. Super administrators and quality administrators can edit and delete any knowledge base. Knowledge base owners can edit and delete the knowledge bases they manage.
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Quality administrators can add or remove quality rules for any knowledge base. Knowledge base owners can only manage quality rules for the knowledge bases they oversee.
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Operation permissions vary for different objects. For more information, see .
Create a knowledge base
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On the Dataphin home page, select Administration > Data Quality from the top menu bar.
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In the left-side navigation pane, choose Governance Workbench > Knowledge Base. On the Knowledge Base page, click the Create Knowledge Base Document button.
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In the Create Knowledge Base panel, enter the required parameters.
Parameter
Description
Basic Information
Title
The title of the knowledge base, up to 128 characters.
Description
A custom description of the knowledge base. We recommend that you explain its purpose based on the business scenario. Up to 512 characters.
Owner
Select the owner of the current knowledge base.
Problem Cause
The details of the problem. Example: Employee onboarding information contains empty values. Up to 1024 characters.
Solution
The solution to the problem. Example: Export the problematic employee information table. After the HR owner completes the information, the IT department uploads the revised table. Up to 1024 characters.
Related Objects
Related Quality Rules
Click Add Related Rules. In the Add Related Rules dialog box, filter quality rules by monitored object type and monitored object.

Related Files
Click Upload Related Files. In the Upload Related Files dialog box, upload files.
Note-
You can select files from local storage to upload. File names must be unique.
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Each knowledge base can contain up to 10 files, with each file no larger than 10 MB.
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Supported file formats include the following: Word (.doc, .docx, .dot, .dotx, .rtf, .html, .xml, .txt), Excel (.xls, .xlsx, .csv), PDF (.pdf), and Images (.jpg, .png, .jpeg).
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Click OK to finalize the knowledge base creation.
View the knowledge base
After creating a knowledge base, you can view, edit, or delete it on the Knowledge Base page.

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Area |
Description |
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① Search Area |
Search for knowledge bases by title or description keywords. |
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② List Area |
Displays the title, owner, and description of the knowledge base. |
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③ Operation Area |
You can view, edit, or delete the knowledge base.
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What to do next
After a knowledge base is linked with quality rules and the governance workbench, you can view the associated knowledge base in these areas. For more information, see
