GetMetaDBInfo
Retrieves the basic metadata information of an engine instance.
Operation description
Before you begin: Activate DataWorks Enterprise Edition or Ultimate Edition before calling this operation. If the edition is not activated, the service returns 403 Forbidden.Access.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
dataworks:* |
get |
*All Resource
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| AppGuid |
string |
No |
The engine ID, in the format of |
odps.some_engine_name |
| ClusterId |
string |
No |
The cluster ID of the EMR cluster. |
abc |
| DatabaseName |
string |
No |
The database of the EMR cluster. |
abc |
| DataSourceType |
string |
No |
The data type. Valid values: odps and emr. |
emr |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
The response. |
||
| RequestId |
string |
The request ID. |
0bc1411515937**** |
| Data |
object |
The basic metadata information. |
|
| Type |
string |
The database type. |
hive |
| Comment |
string |
The comment. |
Comment |
| CreateTime |
integer |
The time when the engine was created. The value is a 13-digit number, for example, |
1541576644000 |
| ProjectId |
integer |
The workspace ID. |
22 |
| ProjectName |
string |
The name of the workspace. |
test |
| AppGuid |
string |
The engine ID, in the format of |
odps.engine_name |
| OwnerName |
string |
The name of the workspace owner. |
my_name |
| OwnerId |
string |
The Alibaba Cloud account ID of the workspace owner. |
userId |
| EnvType |
integer |
The environment type. A value of 0 indicates a non-production table. A value of 1 indicates a production table. |
1 |
| ProjectNameCn |
string |
The display name of the workspace. |
Test project |
| Endpoint |
string |
The service endpoint. |
http://service.odpsstg.aliyun-inc.com/ |
| ClusterBizId |
string |
The EMR cluster ID. |
abc |
| Name |
string |
The database name. |
abc |
| Location |
string |
The data storage address of the EMR database. |
hdfs:// |
| TenantId |
integer |
The tenant ID. |
233 |
| ModifyTime |
integer |
The time when the engine was modified. The value is a 13-digit number, for example, |
1541576644000 |
Examples
Success response
JSON format
{
"RequestId": "0bc1411515937****",
"Data": {
"Type": "hive",
"Comment": "Comment",
"CreateTime": 1541576644000,
"ProjectId": 22,
"ProjectName": "test",
"AppGuid": "odps.engine_name",
"OwnerName": "my_name",
"OwnerId": "userId",
"EnvType": 1,
"ProjectNameCn": "Test project",
"Endpoint": "http://service.odpsstg.aliyun-inc.com/",
"ClusterBizId": "abc",
"Name": "abc",
"Location": "hdfs://",
"TenantId": 233,
"ModifyTime": 1541576644000
}
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | Invalid.Meta.AppNotExist | The MaxCompute project does not exist. | The MaxCompute project does not exist. |
| 400 | InvalidParameter.Meta.CommonError | The specified parameter is invalid. | The request parameter is invalid. |
| 400 | InvalidParameter.Meta.Illegal | The app guid parameter is invalid. | The app guid parameter is invalid. |
| 400 | InvalidParameter.Meta.IllegalDate | The date format is invalid. | The date format is invalid. |
| 400 | InvalidParameter.Meta.IllegalPageError | The parameter for paging is invalid. | The parameter for paging is invalid. |
| 400 | InternalError.UserId.Missing | An internal system error occurred. Try again later. | |
| 400 | InternalError.Meta.NoCalcEngine | An error occurred while retrieving the compute engine based on the MaxCompute project. | Incorrect project entered by user |
| 400 | InvalidParameter.Meta.NotExist | The data does not exist. | No data is available. |
| 500 | InternalError.System | An internal system error occurred. Try again later. | |
| 500 | InternalError.Meta.TenantTimeOut | Failed to connect to the interface network. | Failed to connect to the interface network. |
| 500 | InternalError.Meta.Unknown | An unknown error occurred while processing your request. | An unknown error occurred while processing your request. |
| 403 | Forbidden.Meta.NoTenant | The user is not the owner of any tenants. | The user is not the owner of any tenants. |
| 403 | Forbidden.Access | Access is forbidden. Please first activate DataWorks Enterprise Edition or Flagship Edition. | No permission, please authorize |
| 429 | Throttling.Api | The request for this resource has exceeded your available limit. | |
| 429 | Throttling.Api.Risk | The request for this resource has exceeded your daily available limit. | |
| 429 | Throttling.System | The DataWorks system is busy. Try again later. | |
| 429 | Throttling.User | Your request is too frequent. Try again later. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.