Node failures

更新时间:
复制 MD 格式

This topic provides answers to some frequently asked questions about node failures.

A task configured to retry on failure does not retry after a run failure and reports Task Run Timed Out, Killed by System!!

  • Problem

    A target task fails to rerun after a failure and reports the Task Run Timed Out, Killed by System! error. This issue occurs even when the Rerun in the Time attribute of the task's Scheduling Settings is set to Allow Regardless of Running Status or Do not rerun on success, which allows the task to be rerun after a failure.

  • Cause

    This task's Scheduling Settings has a Timeout configured in its Time attribute. When the task's runtime exceeds the timeout, the task is automatically terminated. A task that fails due to a timeout will not trigger a rerun.

  • Solution:

    Manually rerun the node.

What do I do if the following error is reported for a node when the node is run: OSError: [Errno 7] Argument list too long?

  • Problem description:

    The following error is reported for a node when the node is run: OSError:[Errno 7] Argument list too long.

  • Cause

    The size of the SQL code exceeds the 128 KB limit.

  • Solution:

    Split the SQL code and execute it again.

    Note The number of SQL commands in a single node cannot exceed 200.

ODPS-0420095: Access Denied - Authorization Failed [4093], You have NO privilege to do the restricted operation on {acs:odps:*:projects/xxxx}. Access Mode is AllDenied.

  • Cause:

    The project to which the job you run belongs is disabled.

  • Solution
    • Check whether your account has overdue payments or the subscription for the project's default computing quota has expired. If so, the project is automatically restored after you add funds or renew your subscription. The restoration process can take 2 to 30 minutes, depending on the number of your orders and projects.
    • If the issue is not caused by overdue payments or an expired subscription, the project may have been manually disabled. You can go to the Projects page of the MaxCompute console to restore the project. For more information, see Project Management.

What do I do if the message ODPS-0420061: Invalid parameter in HTTP request - Fetched data is larger than the rendering limitation. Please try to reduce your limit size or column number appears?

Specify a threshold for the number of data records that can be returned in your SQL statement. If you want to obtain more data records, you can export the data records. If you want to obtain more than 10,000 data records, use a Tunnel command to export the data records.

What do I do if the data synchronized by using multiple threads is out of order?

A synchronization node reads data from MaxCompute tables in random order. If you do not configure order settings, the data returned by the synchronization node is also out of order.

By default, the data synchronized from MaxCompute is stored in random order. If you want to obtain sorted data, configure order settings for the synchronized data. For example, you can configure order by xx limit n in the SQL statement of the synchronization node to sort data.

What do I do if my synchronization node that uses an AnalyticDB for MySQL data source and runs on a shared resource group fails to run?

You must activate an exclusive resource group for scheduling, connect it to the VPC, and then rerun the AnalyticDB for MySQL task. For more information, see Test the connectivity of a data source.

When I run a data synchronization node that uses a MySQL data source, the system displays an error message indicating that the Java Database Connectivity (JDBC) driver for the MySQL node is not supported. What do I do?

  • The error message sql execute failed! The JDBC driver is not supported. appears because
  • the MySQL data source that you selected is not added by using the connection string mode.
  • Solution

    Select a data source created in connection string mode. You can go to the Data source management page, find the target data source, and click Edit in the Actions column to check the creation mode on the Edit Data Source page. For more information, see Configure a MySQL data source.

How do I view the logs of a for-each node, do-while node, or PAI node in Operation Center?

Click the name of the desired instance of a for-each node, do-while node, or PAI node on the Cycle Instance page in Operation Center, and right-click the instance in the directed acyclic graph (DAG) of the instance and select View Internal Nodes.

What do I do if the error message error in your condition run fail appears when I run a branch node?

  • Check whether the branch conditions that you specify for the branch node comply with the specifications of the Python syntax.
  • If the output of the ancestor assignment node of the branch node is strings, you must enclose variables in single quotation marks (') for the branch node to reference the variables.

What do I do if the error message None Ftp connection info!! appears when I run an FTP Check node?

  • Problem description: The FTP Check node that is used to check whether the FTP data source contains the Done file fails to run, and the error message None Ftp connection info!! appears.
  • Possible cause: The FTP data source is incorrectly configured. As a result, the FTP Check node fails to obtain information about the FTP data source.
  • Data source managementData source managementData source managementConfigure an FTP data sourceSolution

What do I do if the error message Connect Failed appears when I run an FTP Check node?

  • Problem description: The FTP Check node that is used to check whether the FTP data source contains the Done file fails to run, and the error message Connect Failed appears.
  • Possible cause: The FTP data source fails to connect to the FTP server.
  • telnet IP portDataWorks ConsoleData source managementData source managementData source managementSolution

What do I do if the error message The current time has exceeded the end-check time point! appears when I run an FTP Check node?

  • Problem description: The FTP Check node that is used to check whether the FTP data source contains the Done file fails to run, and the error message The current time has exceeded the end-check time point! appears.
  • Cause

    The current time has passed the specified Time for Stopping Check for monitoring the Done file, which causes the task to fail immediately.

  • Solution

    Based on your business requirements, reconfigure a valid Time for Stopping Check for the FTP Check node task. For more information, see Configure a check policy.

What do I do if the error message File not Exists or exceeded the end-check time point! appears when I run an FTP Check node?

  • Problem description: The FTP Check node that is used to check whether the FTP data source contains the Done file fails to run, and the error message File not Exists or exceeded the end-check time point! appears.
  • Cause

    The task did not find the Done file in the FTP data source before the specified Time for Stopping Check, or the check duration exceeded the configured Time for Stopping Check.

  • Solution: This is an expected error. If this error message appears, DataWorks does not trigger the descendant node of the FTP Check node to run.

Error: no available machine resources under the task resource group

  • Symptom: The Operation Center reports an error.no available machine resources under the task resource group
  • Solution: In the navigation pane on the left of the Operation Center page, click Auto Triggered Task O&M > Auto Triggered Task to change the resource group for scheduling that the task uses.
Modify a resource group for scheduling