Resource does not exist

Updated at:

This topic describes common issues that occur when a resource does not exist and provides solutions.

Group ID does not exist

Possible cause: The Group ID was not created in the console. The server cannot verify the Group ID when a client uses it to connect to the broker.

Solution:

  1. Log on to the Message Queue console, go to Group Management, and then create a Group ID. For more information, see Create a Group ID.

  2. Restart the application.

Hostname does not exist

Possible cause: The system cannot retrieve the hostname or host IP address. To check this, run the hostname command.

  • If the command does not return any output, this is the cause of the error.

  • If the command returns an output, the issue may have a different cause. Contact technical support for assistance.

Solution:

  1. On the machine that is reporting the error, run the command to view the hostname:

    [user1@abc123 ~]# hostname
    abc123

    If the command returns an error, check if an alias is defined for `hostname`. For example, check for `alias xxx='hostname'` in the .bash_profile or .bashrc file. Also, ensure that the command path is in $PATH.

  2. Ping the host:

    [user1@abc123 ~]# ping abc123

    If you cannot ping the hostname, bind the local address in the /etc/hosts file. By default, an ECS instance has a binding between its local address and hostname. Do not remove this binding.

  3. Check the system configuration to ensure that the hostname in /etc/sysconfig/network matches the hostname binding in /etc/hosts.

    If they do not match, modify the /etc/sysconfig/network file. You must restart the machine for the changes to take effect.

    Important

    Do not modify system file configurations unless it is necessary. These changes can cause other issues.

After you complete these steps, the client will no longer report an UnknownHostException error during startup.